CVE-2009-1789

Description

mod/server.mod/servmsg.c in Eggheads Eggdrop and Windrop 1.6.19 and earlier allows remote attackers to cause a denial of service (crash) via a crafted PRIVMSG that causes an empty string to trigger a negative string length copy. NOTE: this issue exists because of an incorrect fix for CVE-2007-2807.

Related Vulnerabilities

platform vulnerability
CVE-2009-1789 eggdrop
CVE-2009-1789