CVE-2009-2295

Metadata

CVE-2009-2295
7.5
debian.org, ocert.org, securityfocus.com, securityfocus.com, vupen.com
2009-07-05
2017-06-06 20:20

Description

Multiple integer overflows in CamlImages 2.2 and earlier might allow context-dependent attackers to execute arbitrary code via a crafted PNG image with large width and height values that trigger a heap-based buffer overflow in the (1) read_png_file or (2) read_png_file_as_rgb24 function.

Related Vulnerabilities

platform vulnerability
CVE-2009-2295 advi
CVE-2009-2295 camlimages
CVE-2009-2295