CVE-2009-2409

Description

The Network Security Services (NSS) library before 3.12.3, as used in Firefox; GnuTLS before 2.6.4 and 2.7.4; OpenSSL 0.9.8 through 0.9.8k; and other products support MD2 with X.509 certificates, which might allow remote attackers to spoof certificates by using MD2 design flaws to generate a hash collision in less than brute-force time. NOTE: the scope of this issue is currently limited because the amount of computation required is still large.

Related Vulnerabilities

platform vulnerability
CVE-2009-2409 openjdk-6
CVE-2009-2409 openssl
CVE-2009-2409 nss
CVE-2009-2409 gnutls26
CVE-2009-2409