CVE-2009-2669

Metadata

CVE-2009-2669
7.2
aix.software.ibm.com, labs.idefense.com, ibm.com, ibm.com, ibm.com, ibm.com, securityfocus.com, vupen.com
2009-08-05
2017-06-06 20:20

Description

A certain debugging component in IBM AIX 5.3 and 6.1 does not properly handle the (1) _LIB_INIT_DBG and (2) _LIB_INIT_DBG_FILE environment variables, which allows local users to gain privileges by leveraging a setuid-root program to create an arbitrary root-owned file with world-writable permissions, related to libC.a (aka the XL C++ runtime library) in AIX 5.3 and libc.a in AIX 6.1.

Related Vulnerabilities