CVE-2009-2737

Metadata

CVE-2009-2737
5.5
bugs.debian.org, issues.roundup-tracker.org, debian.org, securityfocus.com, bugzilla.redhat.com, redhat.com, redhat.com
2009-08-11
2017-06-06 20:20

Description

The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.

Related Vulnerabilities

platform vulnerability
CVE-2009-2737 roundup
CVE-2009-2737