CVE-2009-2958

Metadata

CVE-2009-2958
4.3
coresecurity.com, redhat.com, securityfocus.com, thekelleys.org.uk, ubuntu.com, bugzilla.redhat.com, rhn.redhat.com
2009-09-02
2017-09-21 21:08

Description

The tftp_request function in tftp.c in dnsmasq before 2.50, when --enable-tftp is used, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a TFTP read (aka RRQ) request with a malformed blksize option.

Related Vulnerabilities

platform vulnerability
CVE-2009-2958 dnsmasq
CVE-2009-2958