CVE-2009-3474

Metadata

CVE-2009-3474
7.5
shibboleth.internet2.edu, debian.org, debian.org, securityfocus.com, bugs.internet2.edu, exchange.xforce.ibmcloud.com
2009-09-29
2017-08-17 06:09

Description

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Related Vulnerabilities

platform vulnerability
CVE-2009-3474 opensaml2
CVE-2009-3474 xmltooling
CVE-2009-3474 shibboleth-sp2
CVE-2009-3474