CVE-2009-3609

Description

Integer overflow in the ImageStream::ImageStream function in Stream.cc in Xpdf before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, and CUPS pdftops, allows remote attackers to cause a denial of service (application crash) via a crafted PDF document that triggers a NULL pointer dereference or buffer over-read.

Related Vulnerabilities

platform vulnerability
CVE-2009-3609 xpdf
CVE-2009-3609 poppler
CVE-2009-3609 swftools
CVE-2009-3609