CVE-2009-3617

Metadata

CVE-2009-3617
7.6
aria2.svn.sourceforge.net, aria2.svn.sourceforge.net, marc.info, marc.info, vupen.com, bugzilla.redhat.com, fedorahosted.org
2009-10-20
2017-06-06 20:21

Description

Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.

Related Vulnerabilities

platform vulnerability
CVE-2009-3617 aria2
CVE-2009-3617