CVE-2009-3720

Description

The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

Related Vulnerabilities

platform vulnerability
CVE-2009-3720 wxwidgets2.8
CVE-2009-3720 insighttoolkit
CVE-2009-3720 vxl
CVE-2009-3720 ayttm
CVE-2009-3720 simgear
CVE-2009-3720 xulrunner
CVE-2009-3720 mcabber
CVE-2009-3720 cmake
CVE-2009-3720 udunits
CVE-2009-3720 gdcm
CVE-2009-3720 xmlrpc-c
CVE-2009-3720 iceweasel
CVE-2009-3720 smart
CVE-2009-3720 tla
CVE-2009-3720 centerim
CVE-2009-3720 ghostscript
CVE-2009-3720 expat
CVE-2009-3720 xotcl
CVE-2009-3720 coin3
CVE-2009-3720 vnc4
CVE-2009-3720 paraview
CVE-2009-3720 poco
CVE-2009-3720 tdom
CVE-2009-3720 cadaver
CVE-2009-3720 matanza
CVE-2009-3720 audacity
CVE-2009-3720 texlive-bin
CVE-2009-3720 cableswig
CVE-2009-3720