CVE-2009-3978

Metadata

CVE-2009-3978
4.3
hg.mozilla.org, h-online.com, mozilla.com, bugzilla.mozilla.org, wiki.mozilla.org
2009-11-19
2017-06-06 20:21

Description

The nsGIFDecoder2::GifWrite function in decoders/gif/nsGIFDecoder2.cpp in libpr0n in Mozilla Firefox before 3.5.5 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an animated GIF file with a large image size, a different vulnerability than CVE-2009-3373.

Related Vulnerabilities

platform vulnerability
CVE-2009-3978 xulrunner
CVE-2009-3978