Moderate CentOS libpng Update

Metadata

medium
unknown
libpng-1.2.10-17.el5_8.i386.rpm, libpng-1.2.10-17.el5_8.src.rpm, libpng-1.2.10-17.el5_8.x86_64.rpm, libpng-1.2.49-1.el6_2.i686.rpm, libpng-1.2.49-1.el6_2.src.rpm, libpng-1.2.49-1.el6_2.x86_64.rpm, libpng-devel-1.2.10-17.el5_8.i386.rpm, libpng-devel-1.2.10-17.el5_8.x86_64.rpm, libpng-devel-1.2.49-1.el6_2.i686.rpm, libpng-devel-1.2.49-1.el6_2.x86_64.rpm, libpng-static-1.2.49-1.el6_2.i686.rpm, libpng-static-1.2.49-1.el6_2.x86_64.rpm
rhn.redhat.com, lists.centos.org, lists.centos.org
2012-04-25
2017-07-27 20:03
2017-07-27 19:03
2017-04-01 19:05
2017-01-05 20:09

Description


Updated libpng packages that fix one security issue are now available for
Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

The libpng packages contain a library of functions for creating and
manipulating PNG (Portable Network Graphics) image format files.

A heap-based buffer overflow flaw was found in the way libpng processed
tEXt chunks in PNG image files. An attacker could create a
specially-crafted PNG image file that, when opened, could cause an
application using libpng to crash or, possibly, execute arbitrary code with
the privileges of the user running the application. (CVE-2011-3048)

Users of libpng should upgrade to these updated packages, which correct
this issue. For Red Hat Enterprise Linux 5, they contain a backported
patch. For Red Hat Enterprise Linux 6, they upgrade libpng to version
1.2.49. All running applications using libpng must be restarted for the
update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 libpng libpng-1.2.10-17.el5_8.i386.rpm
libpng libpng-1.2.10-17.el5_8.src.rpm
libpng libpng-1.2.10-17.el5_8.x86_64.rpm
libpng-devel libpng-devel-1.2.10-17.el5_8.i386.rpm
libpng-devel libpng-devel-1.2.10-17.el5_8.x86_64.rpm
6 libpng libpng-1.2.49-1.el6_2.i686.rpm
libpng libpng-1.2.49-1.el6_2.src.rpm
libpng libpng-1.2.49-1.el6_2.x86_64.rpm
libpng-devel libpng-devel-1.2.49-1.el6_2.i686.rpm
libpng-devel libpng-devel-1.2.49-1.el6_2.x86_64.rpm
libpng-static libpng-static-1.2.49-1.el6_2.i686.rpm
libpng-static libpng-static-1.2.49-1.el6_2.x86_64.rpm