Critical CentOS php Update

Metadata

critical
unknown
php-5.1.6-34.el5_8.i386.rpm, php-5.1.6-34.el5_8.src.rpm, php-5.1.6-34.el5_8.x86_64.rpm, php-5.3.3-3.el6_2.8.i686.rpm, php-5.3.3-3.el6_2.8.src.rpm, php-5.3.3-3.el6_2.8.x86_64.rpm, php-bcmath-5.1.6-34.el5_8.i386.rpm, php-bcmath-5.1.6-34.el5_8.x86_64.rpm, php-bcmath-5.3.3-3.el6_2.8.i686.rpm, php-bcmath-5.3.3-3.el6_2.8.x86_64.rpm, php-cli-5.1.6-34.el5_8.i386.rpm, php-cli-5.1.6-34.el5_8.x86_64.rpm, php-cli-5.3.3-3.el6_2.8.i686.rpm, php-cli-5.3.3-3.el6_2.8.x86_64.rpm, php-common-5.1.6-34.el5_8.i386.rpm, php-common-5.1.6-34.el5_8.x86_64.rpm, php-common-5.3.3-3.el6_2.8.i686.rpm, php-common-5.3.3-3.el6_2.8.x86_64.rpm, php-dba-5.1.6-34.el5_8.i386.rpm, php-dba-5.1.6-34.el5_8.x86_64.rpm, php-dba-5.3.3-3.el6_2.8.i686.rpm, php-dba-5.3.3-3.el6_2.8.x86_64.rpm, php-devel-5.1.6-34.el5_8.i386.rpm, php-devel-5.1.6-34.el5_8.x86_64.rpm, php-devel-5.3.3-3.el6_2.8.i686.rpm, php-devel-5.3.3-3.el6_2.8.x86_64.rpm, php-embedded-5.3.3-3.el6_2.8.i686.rpm, php-embedded-5.3.3-3.el6_2.8.x86_64.rpm, php-enchant-5.3.3-3.el6_2.8.i686.rpm, php-enchant-5.3.3-3.el6_2.8.x86_64.rpm, php-gd-5.1.6-34.el5_8.i386.rpm, php-gd-5.1.6-34.el5_8.x86_64.rpm, php-gd-5.3.3-3.el6_2.8.i686.rpm, php-gd-5.3.3-3.el6_2.8.x86_64.rpm, php-imap-5.1.6-34.el5_8.i386.rpm, php-imap-5.1.6-34.el5_8.x86_64.rpm, php-imap-5.3.3-3.el6_2.8.i686.rpm, php-imap-5.3.3-3.el6_2.8.x86_64.rpm, php-intl-5.3.3-3.el6_2.8.i686.rpm, php-intl-5.3.3-3.el6_2.8.x86_64.rpm, php-ldap-5.1.6-34.el5_8.i386.rpm, php-ldap-5.1.6-34.el5_8.x86_64.rpm, php-ldap-5.3.3-3.el6_2.8.i686.rpm, php-ldap-5.3.3-3.el6_2.8.x86_64.rpm, php-mbstring-5.1.6-34.el5_8.i386.rpm, php-mbstring-5.1.6-34.el5_8.x86_64.rpm, php-mbstring-5.3.3-3.el6_2.8.i686.rpm, php-mbstring-5.3.3-3.el6_2.8.x86_64.rpm, php-mysql-5.1.6-34.el5_8.i386.rpm, php-mysql-5.1.6-34.el5_8.x86_64.rpm, php-mysql-5.3.3-3.el6_2.8.i686.rpm, php-mysql-5.3.3-3.el6_2.8.x86_64.rpm, php-ncurses-5.1.6-34.el5_8.i386.rpm, php-ncurses-5.1.6-34.el5_8.x86_64.rpm, php-odbc-5.1.6-34.el5_8.i386.rpm, php-odbc-5.1.6-34.el5_8.x86_64.rpm, php-odbc-5.3.3-3.el6_2.8.i686.rpm, php-odbc-5.3.3-3.el6_2.8.x86_64.rpm, php-pdo-5.1.6-34.el5_8.i386.rpm, php-pdo-5.1.6-34.el5_8.x86_64.rpm, php-pdo-5.3.3-3.el6_2.8.i686.rpm, php-pdo-5.3.3-3.el6_2.8.x86_64.rpm, php-pgsql-5.1.6-34.el5_8.i386.rpm, php-pgsql-5.1.6-34.el5_8.x86_64.rpm, php-pgsql-5.3.3-3.el6_2.8.i686.rpm, php-pgsql-5.3.3-3.el6_2.8.x86_64.rpm, php-process-5.3.3-3.el6_2.8.i686.rpm, php-process-5.3.3-3.el6_2.8.x86_64.rpm, php-pspell-5.3.3-3.el6_2.8.i686.rpm, php-pspell-5.3.3-3.el6_2.8.x86_64.rpm, php-recode-5.3.3-3.el6_2.8.i686.rpm, php-recode-5.3.3-3.el6_2.8.x86_64.rpm, php-snmp-5.1.6-34.el5_8.i386.rpm, php-snmp-5.1.6-34.el5_8.x86_64.rpm, php-snmp-5.3.3-3.el6_2.8.i686.rpm, php-snmp-5.3.3-3.el6_2.8.x86_64.rpm, php-soap-5.1.6-34.el5_8.i386.rpm, php-soap-5.1.6-34.el5_8.x86_64.rpm, php-soap-5.3.3-3.el6_2.8.i686.rpm, php-soap-5.3.3-3.el6_2.8.x86_64.rpm, php-tidy-5.3.3-3.el6_2.8.i686.rpm, php-tidy-5.3.3-3.el6_2.8.x86_64.rpm, php-xml-5.1.6-34.el5_8.i386.rpm, php-xml-5.1.6-34.el5_8.x86_64.rpm, php-xml-5.3.3-3.el6_2.8.i686.rpm, php-xml-5.3.3-3.el6_2.8.x86_64.rpm, php-xmlrpc-5.1.6-34.el5_8.i386.rpm, php-xmlrpc-5.1.6-34.el5_8.x86_64.rpm, php-xmlrpc-5.3.3-3.el6_2.8.i686.rpm, php-xmlrpc-5.3.3-3.el6_2.8.x86_64.rpm, php-zts-5.3.3-3.el6_2.8.i686.rpm, php-zts-5.3.3-3.el6_2.8.x86_64.rpm
rhn.redhat.com, lists.centos.org, lists.centos.org
2012-05-07
2017-07-27 20:03
2017-07-27 19:03
2017-04-01 19:05
2017-01-05 20:09

Description


Updated php packages that fix one security issue are now available for
Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP Server.

A flaw was found in the way the php-cgi executable processed command line
arguments when running in CGI mode. A remote attacker could send a
specially-crafted request to a PHP script that would result in the query
string being parsed by php-cgi as command line options and arguments. This
could lead to the disclosure of the script's source code or arbitrary code
execution with the privileges of the PHP interpreter. (CVE-2012-1823)

Red Hat is aware that a public exploit for this issue is available that
allows remote code execution in affected PHP CGI configurations. This flaw
does not affect the default configuration in Red Hat Enterprise Linux 5 and
6 using the PHP module for Apache httpd to handle PHP scripts.

All php users should upgrade to these updated packages, which contain a
backported patch to resolve this issue. After installing the updated
packages, the httpd daemon must be restarted for the update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 php php-5.1.6-34.el5_8.i386.rpm
php php-5.1.6-34.el5_8.src.rpm
php php-5.1.6-34.el5_8.x86_64.rpm
php-bcmath php-bcmath-5.1.6-34.el5_8.i386.rpm
php-bcmath php-bcmath-5.1.6-34.el5_8.x86_64.rpm
php-cli php-cli-5.1.6-34.el5_8.i386.rpm
php-cli php-cli-5.1.6-34.el5_8.x86_64.rpm
php-common php-common-5.1.6-34.el5_8.i386.rpm
php-common php-common-5.1.6-34.el5_8.x86_64.rpm
php-dba php-dba-5.1.6-34.el5_8.i386.rpm
php-dba php-dba-5.1.6-34.el5_8.x86_64.rpm
php-devel php-devel-5.1.6-34.el5_8.i386.rpm
php-devel php-devel-5.1.6-34.el5_8.x86_64.rpm
php-gd php-gd-5.1.6-34.el5_8.i386.rpm
php-gd php-gd-5.1.6-34.el5_8.x86_64.rpm
php-imap php-imap-5.1.6-34.el5_8.i386.rpm
php-imap php-imap-5.1.6-34.el5_8.x86_64.rpm
php-ldap php-ldap-5.1.6-34.el5_8.i386.rpm
php-ldap php-ldap-5.1.6-34.el5_8.x86_64.rpm
php-mbstring php-mbstring-5.1.6-34.el5_8.i386.rpm
php-mbstring php-mbstring-5.1.6-34.el5_8.x86_64.rpm
php-mysql php-mysql-5.1.6-34.el5_8.i386.rpm
php-mysql php-mysql-5.1.6-34.el5_8.x86_64.rpm
php-ncurses php-ncurses-5.1.6-34.el5_8.i386.rpm
php-ncurses php-ncurses-5.1.6-34.el5_8.x86_64.rpm
php-odbc php-odbc-5.1.6-34.el5_8.i386.rpm
php-odbc php-odbc-5.1.6-34.el5_8.x86_64.rpm
php-pdo php-pdo-5.1.6-34.el5_8.i386.rpm
php-pdo php-pdo-5.1.6-34.el5_8.x86_64.rpm
php-pgsql php-pgsql-5.1.6-34.el5_8.i386.rpm
php-pgsql php-pgsql-5.1.6-34.el5_8.x86_64.rpm
php-snmp php-snmp-5.1.6-34.el5_8.i386.rpm
php-snmp php-snmp-5.1.6-34.el5_8.x86_64.rpm
php-soap php-soap-5.1.6-34.el5_8.i386.rpm
php-soap php-soap-5.1.6-34.el5_8.x86_64.rpm
php-xml php-xml-5.1.6-34.el5_8.i386.rpm
php-xml php-xml-5.1.6-34.el5_8.x86_64.rpm
php-xmlrpc php-xmlrpc-5.1.6-34.el5_8.i386.rpm
php-xmlrpc php-xmlrpc-5.1.6-34.el5_8.x86_64.rpm
6 php php-5.3.3-3.el6_2.8.i686.rpm
php php-5.3.3-3.el6_2.8.src.rpm
php php-5.3.3-3.el6_2.8.x86_64.rpm
php-bcmath php-bcmath-5.3.3-3.el6_2.8.i686.rpm
php-bcmath php-bcmath-5.3.3-3.el6_2.8.x86_64.rpm
php-cli php-cli-5.3.3-3.el6_2.8.i686.rpm
php-cli php-cli-5.3.3-3.el6_2.8.x86_64.rpm
php-common php-common-5.3.3-3.el6_2.8.i686.rpm
php-common php-common-5.3.3-3.el6_2.8.x86_64.rpm
php-dba php-dba-5.3.3-3.el6_2.8.i686.rpm
php-dba php-dba-5.3.3-3.el6_2.8.x86_64.rpm
php-devel php-devel-5.3.3-3.el6_2.8.i686.rpm
php-devel php-devel-5.3.3-3.el6_2.8.x86_64.rpm
php-embedded php-embedded-5.3.3-3.el6_2.8.i686.rpm
php-embedded php-embedded-5.3.3-3.el6_2.8.x86_64.rpm
php-enchant php-enchant-5.3.3-3.el6_2.8.i686.rpm
php-enchant php-enchant-5.3.3-3.el6_2.8.x86_64.rpm
php-gd php-gd-5.3.3-3.el6_2.8.i686.rpm
php-gd php-gd-5.3.3-3.el6_2.8.x86_64.rpm
php-imap php-imap-5.3.3-3.el6_2.8.i686.rpm
php-imap php-imap-5.3.3-3.el6_2.8.x86_64.rpm
php-intl php-intl-5.3.3-3.el6_2.8.i686.rpm
php-intl php-intl-5.3.3-3.el6_2.8.x86_64.rpm
php-ldap php-ldap-5.3.3-3.el6_2.8.i686.rpm
php-ldap php-ldap-5.3.3-3.el6_2.8.x86_64.rpm
php-mbstring php-mbstring-5.3.3-3.el6_2.8.i686.rpm
php-mbstring php-mbstring-5.3.3-3.el6_2.8.x86_64.rpm
php-mysql php-mysql-5.3.3-3.el6_2.8.i686.rpm
php-mysql php-mysql-5.3.3-3.el6_2.8.x86_64.rpm
php-odbc php-odbc-5.3.3-3.el6_2.8.i686.rpm
php-odbc php-odbc-5.3.3-3.el6_2.8.x86_64.rpm
php-pdo php-pdo-5.3.3-3.el6_2.8.i686.rpm
php-pdo php-pdo-5.3.3-3.el6_2.8.x86_64.rpm
php-pgsql php-pgsql-5.3.3-3.el6_2.8.i686.rpm
php-pgsql php-pgsql-5.3.3-3.el6_2.8.x86_64.rpm
php-process php-process-5.3.3-3.el6_2.8.i686.rpm
php-process php-process-5.3.3-3.el6_2.8.x86_64.rpm
php-pspell php-pspell-5.3.3-3.el6_2.8.i686.rpm
php-pspell php-pspell-5.3.3-3.el6_2.8.x86_64.rpm
php-recode php-recode-5.3.3-3.el6_2.8.i686.rpm
php-recode php-recode-5.3.3-3.el6_2.8.x86_64.rpm
php-snmp php-snmp-5.3.3-3.el6_2.8.i686.rpm
php-snmp php-snmp-5.3.3-3.el6_2.8.x86_64.rpm
php-soap php-soap-5.3.3-3.el6_2.8.i686.rpm
php-soap php-soap-5.3.3-3.el6_2.8.x86_64.rpm
php-tidy php-tidy-5.3.3-3.el6_2.8.i686.rpm
php-tidy php-tidy-5.3.3-3.el6_2.8.x86_64.rpm
php-xml php-xml-5.3.3-3.el6_2.8.i686.rpm
php-xml php-xml-5.3.3-3.el6_2.8.x86_64.rpm
php-xmlrpc php-xmlrpc-5.3.3-3.el6_2.8.i686.rpm
php-xmlrpc php-xmlrpc-5.3.3-3.el6_2.8.x86_64.rpm
php-zts php-zts-5.3.3-3.el6_2.8.i686.rpm
php-zts php-zts-5.3.3-3.el6_2.8.x86_64.rpm