Critical CentOS php53 Update

Metadata

high
7.5
php53-5.3.3-7.el5_8.i386.rpm, php53-5.3.3-7.el5_8.src.rpm, php53-5.3.3-7.el5_8.x86_64.rpm, php53-bcmath-5.3.3-7.el5_8.i386.rpm, php53-bcmath-5.3.3-7.el5_8.x86_64.rpm, php53-cli-5.3.3-7.el5_8.i386.rpm, php53-cli-5.3.3-7.el5_8.x86_64.rpm, php53-common-5.3.3-7.el5_8.i386.rpm, php53-common-5.3.3-7.el5_8.x86_64.rpm, php53-dba-5.3.3-7.el5_8.i386.rpm, php53-dba-5.3.3-7.el5_8.x86_64.rpm, php53-devel-5.3.3-7.el5_8.i386.rpm, php53-devel-5.3.3-7.el5_8.x86_64.rpm, php53-gd-5.3.3-7.el5_8.i386.rpm, php53-gd-5.3.3-7.el5_8.x86_64.rpm, php53-imap-5.3.3-7.el5_8.i386.rpm, php53-imap-5.3.3-7.el5_8.x86_64.rpm, php53-intl-5.3.3-7.el5_8.i386.rpm, php53-intl-5.3.3-7.el5_8.x86_64.rpm, php53-ldap-5.3.3-7.el5_8.i386.rpm, php53-ldap-5.3.3-7.el5_8.x86_64.rpm, php53-mbstring-5.3.3-7.el5_8.i386.rpm, php53-mbstring-5.3.3-7.el5_8.x86_64.rpm, php53-mysql-5.3.3-7.el5_8.i386.rpm, php53-mysql-5.3.3-7.el5_8.x86_64.rpm, php53-odbc-5.3.3-7.el5_8.i386.rpm, php53-odbc-5.3.3-7.el5_8.x86_64.rpm, php53-pdo-5.3.3-7.el5_8.i386.rpm, php53-pdo-5.3.3-7.el5_8.x86_64.rpm, php53-pgsql-5.3.3-7.el5_8.i386.rpm, php53-pgsql-5.3.3-7.el5_8.x86_64.rpm, php53-process-5.3.3-7.el5_8.i386.rpm, php53-process-5.3.3-7.el5_8.x86_64.rpm, php53-pspell-5.3.3-7.el5_8.i386.rpm, php53-pspell-5.3.3-7.el5_8.x86_64.rpm, php53-snmp-5.3.3-7.el5_8.i386.rpm, php53-snmp-5.3.3-7.el5_8.x86_64.rpm, php53-soap-5.3.3-7.el5_8.i386.rpm, php53-soap-5.3.3-7.el5_8.x86_64.rpm, php53-xml-5.3.3-7.el5_8.i386.rpm, php53-xml-5.3.3-7.el5_8.x86_64.rpm, php53-xmlrpc-5.3.3-7.el5_8.i386.rpm, php53-xmlrpc-5.3.3-7.el5_8.x86_64.rpm
CVE-2012-1823
rhn.redhat.com, lists.centos.org
2012-05-07
2017-07-27 19:03
ALAS-2012-77
CVE-2012-1823 php5
CVE-2012-1823
2017-04-01 19:05
2017-01-05 20:09

Description


Updated php53 packages that fix one security issue are now available for
Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP Server.

A flaw was found in the way the php-cgi executable processed command line
arguments when running in CGI mode. A remote attacker could send a
specially-crafted request to a PHP script that would result in the query
string being parsed by php-cgi as command line options and arguments. This
could lead to the disclosure of the script's source code or arbitrary code
execution with the privileges of the PHP interpreter. (CVE-2012-1823)

Red Hat is aware that a public exploit for this issue is available that
allows remote code execution in affected PHP CGI configurations. This flaw
does not affect the default configuration using the PHP module for Apache
httpd to handle PHP scripts.

All php53 users should upgrade to these updated packages, which contain a
backported patch to resolve this issue. After installing the updated
packages, the httpd daemon must be restarted for the update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 php53 php53-5.3.3-7.el5_8.x86_64.rpm
php53 php53-5.3.3-7.el5_8.i386.rpm
php53 php53-5.3.3-7.el5_8.src.rpm
php53-bcmath php53-bcmath-5.3.3-7.el5_8.i386.rpm
php53-bcmath php53-bcmath-5.3.3-7.el5_8.x86_64.rpm
php53-cli php53-cli-5.3.3-7.el5_8.i386.rpm
php53-cli php53-cli-5.3.3-7.el5_8.x86_64.rpm
php53-common php53-common-5.3.3-7.el5_8.i386.rpm
php53-common php53-common-5.3.3-7.el5_8.x86_64.rpm
php53-dba php53-dba-5.3.3-7.el5_8.i386.rpm
php53-dba php53-dba-5.3.3-7.el5_8.x86_64.rpm
php53-devel php53-devel-5.3.3-7.el5_8.i386.rpm
php53-devel php53-devel-5.3.3-7.el5_8.x86_64.rpm
php53-gd php53-gd-5.3.3-7.el5_8.i386.rpm
php53-gd php53-gd-5.3.3-7.el5_8.x86_64.rpm
php53-imap php53-imap-5.3.3-7.el5_8.i386.rpm
php53-imap php53-imap-5.3.3-7.el5_8.x86_64.rpm
php53-intl php53-intl-5.3.3-7.el5_8.i386.rpm
php53-intl php53-intl-5.3.3-7.el5_8.x86_64.rpm
php53-ldap php53-ldap-5.3.3-7.el5_8.i386.rpm
php53-ldap php53-ldap-5.3.3-7.el5_8.x86_64.rpm
php53-mbstring php53-mbstring-5.3.3-7.el5_8.i386.rpm
php53-mbstring php53-mbstring-5.3.3-7.el5_8.x86_64.rpm
php53-mysql php53-mysql-5.3.3-7.el5_8.i386.rpm
php53-mysql php53-mysql-5.3.3-7.el5_8.x86_64.rpm
php53-odbc php53-odbc-5.3.3-7.el5_8.i386.rpm
php53-odbc php53-odbc-5.3.3-7.el5_8.x86_64.rpm
php53-pdo php53-pdo-5.3.3-7.el5_8.i386.rpm
php53-pdo php53-pdo-5.3.3-7.el5_8.x86_64.rpm
php53-pgsql php53-pgsql-5.3.3-7.el5_8.i386.rpm
php53-pgsql php53-pgsql-5.3.3-7.el5_8.x86_64.rpm
php53-process php53-process-5.3.3-7.el5_8.i386.rpm
php53-process php53-process-5.3.3-7.el5_8.x86_64.rpm
php53-pspell php53-pspell-5.3.3-7.el5_8.i386.rpm
php53-pspell php53-pspell-5.3.3-7.el5_8.x86_64.rpm
php53-snmp php53-snmp-5.3.3-7.el5_8.i386.rpm
php53-snmp php53-snmp-5.3.3-7.el5_8.x86_64.rpm
php53-soap php53-soap-5.3.3-7.el5_8.i386.rpm
php53-soap php53-soap-5.3.3-7.el5_8.x86_64.rpm
php53-xml php53-xml-5.3.3-7.el5_8.i386.rpm
php53-xml php53-xml-5.3.3-7.el5_8.x86_64.rpm
php53-xmlrpc php53-xmlrpc-5.3.3-7.el5_8.i386.rpm
php53-xmlrpc php53-xmlrpc-5.3.3-7.el5_8.x86_64.rpm