Moderate CentOS pidgin Update

Metadata

medium
unknown
finch-2.6.6-11.el5.4.i386.rpm, finch-2.6.6-11.el5.4.x86_64.rpm, finch-2.7.9-5.el6.2.i686.rpm, finch-2.7.9-5.el6.2.x86_64.rpm, finch-devel-2.6.6-11.el5.4.i386.rpm, finch-devel-2.6.6-11.el5.4.x86_64.rpm, finch-devel-2.7.9-5.el6.2.i686.rpm, finch-devel-2.7.9-5.el6.2.x86_64.rpm, libpurple-2.6.6-11.el5.4.i386.rpm, libpurple-2.6.6-11.el5.4.x86_64.rpm, libpurple-2.7.9-5.el6.2.i686.rpm, libpurple-2.7.9-5.el6.2.x86_64.rpm, libpurple-devel-2.6.6-11.el5.4.i386.rpm, libpurple-devel-2.6.6-11.el5.4.x86_64.rpm, libpurple-devel-2.7.9-5.el6.2.i686.rpm, libpurple-devel-2.7.9-5.el6.2.x86_64.rpm, libpurple-perl-2.6.6-11.el5.4.i386.rpm, libpurple-perl-2.6.6-11.el5.4.x86_64.rpm, libpurple-perl-2.7.9-5.el6.2.i686.rpm, libpurple-perl-2.7.9-5.el6.2.x86_64.rpm, libpurple-tcl-2.6.6-11.el5.4.i386.rpm, libpurple-tcl-2.6.6-11.el5.4.x86_64.rpm, libpurple-tcl-2.7.9-5.el6.2.i686.rpm, libpurple-tcl-2.7.9-5.el6.2.x86_64.rpm, pidgin-2.6.6-11.el5.4.i386.rpm, pidgin-2.6.6-11.el5.4.src.rpm, pidgin-2.6.6-11.el5.4.x86_64.rpm, pidgin-2.7.9-5.el6.2.i686.rpm, pidgin-2.7.9-5.el6.2.src.rpm, pidgin-2.7.9-5.el6.2.x86_64.rpm, pidgin-devel-2.6.6-11.el5.4.i386.rpm, pidgin-devel-2.6.6-11.el5.4.x86_64.rpm, pidgin-devel-2.7.9-5.el6.2.i686.rpm, pidgin-devel-2.7.9-5.el6.2.x86_64.rpm, pidgin-docs-2.7.9-5.el6.2.i686.rpm, pidgin-docs-2.7.9-5.el6.2.x86_64.rpm, pidgin-perl-2.6.6-11.el5.4.i386.rpm, pidgin-perl-2.6.6-11.el5.4.x86_64.rpm, pidgin-perl-2.7.9-5.el6.2.i686.rpm, pidgin-perl-2.7.9-5.el6.2.x86_64.rpm
rhn.redhat.com, lists.centos.org, lists.centos.org
2012-07-19
2017-07-27 20:03
2017-07-27 19:03
2017-04-01 19:06
2017-01-05 20:10

Description


Updated pidgin packages that fix three security issues are now available
for Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

Pidgin is an instant messaging program which can log in to multiple
accounts on multiple instant messaging networks simultaneously.

A flaw was found in the way the Pidgin MSN protocol plug-in processed text
that was not encoded in UTF-8. A remote attacker could use this flaw to
crash Pidgin by sending a specially-crafted MSN message. (CVE-2012-1178)

An input validation flaw was found in the way the Pidgin MSN protocol
plug-in handled MSN notification messages. A malicious server or a remote
attacker could use this flaw to crash Pidgin by sending a specially-crafted
MSN notification message. (CVE-2012-2318)

A buffer overflow flaw was found in the Pidgin MXit protocol plug-in. A
remote attacker could use this flaw to crash Pidgin by sending a MXit
message containing specially-crafted emoticon tags. (CVE-2012-3374)

Red Hat would like to thank the Pidgin project for reporting the
CVE-2012-3374 issue. Upstream acknowledges Ulf Härnhammar as the original
reporter of CVE-2012-3374.

All Pidgin users should upgrade to these updated packages, which contain
backported patches to resolve these issues. Pidgin must be restarted for
this update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 finch finch-2.6.6-11.el5.4.x86_64.rpm
finch finch-2.6.6-11.el5.4.i386.rpm
finch-devel finch-devel-2.6.6-11.el5.4.i386.rpm
finch-devel finch-devel-2.6.6-11.el5.4.x86_64.rpm
libpurple libpurple-2.6.6-11.el5.4.i386.rpm
libpurple libpurple-2.6.6-11.el5.4.x86_64.rpm
libpurple-devel libpurple-devel-2.6.6-11.el5.4.i386.rpm
libpurple-devel libpurple-devel-2.6.6-11.el5.4.x86_64.rpm
libpurple-perl libpurple-perl-2.6.6-11.el5.4.i386.rpm
libpurple-perl libpurple-perl-2.6.6-11.el5.4.x86_64.rpm
libpurple-tcl libpurple-tcl-2.6.6-11.el5.4.i386.rpm
libpurple-tcl libpurple-tcl-2.6.6-11.el5.4.x86_64.rpm
pidgin pidgin-2.6.6-11.el5.4.i386.rpm
pidgin pidgin-2.6.6-11.el5.4.src.rpm
pidgin pidgin-2.6.6-11.el5.4.x86_64.rpm
pidgin-devel pidgin-devel-2.6.6-11.el5.4.i386.rpm
pidgin-devel pidgin-devel-2.6.6-11.el5.4.x86_64.rpm
pidgin-perl pidgin-perl-2.6.6-11.el5.4.i386.rpm
pidgin-perl pidgin-perl-2.6.6-11.el5.4.x86_64.rpm
6 finch finch-2.7.9-5.el6.2.i686.rpm
finch finch-2.7.9-5.el6.2.x86_64.rpm
finch-devel finch-devel-2.7.9-5.el6.2.i686.rpm
finch-devel finch-devel-2.7.9-5.el6.2.x86_64.rpm
libpurple libpurple-2.7.9-5.el6.2.i686.rpm
libpurple libpurple-2.7.9-5.el6.2.x86_64.rpm
libpurple-devel libpurple-devel-2.7.9-5.el6.2.i686.rpm
libpurple-devel libpurple-devel-2.7.9-5.el6.2.x86_64.rpm
libpurple-perl libpurple-perl-2.7.9-5.el6.2.i686.rpm
libpurple-perl libpurple-perl-2.7.9-5.el6.2.x86_64.rpm
libpurple-tcl libpurple-tcl-2.7.9-5.el6.2.i686.rpm
libpurple-tcl libpurple-tcl-2.7.9-5.el6.2.x86_64.rpm
pidgin pidgin-2.7.9-5.el6.2.i686.rpm
pidgin pidgin-2.7.9-5.el6.2.src.rpm
pidgin pidgin-2.7.9-5.el6.2.x86_64.rpm
pidgin-devel pidgin-devel-2.7.9-5.el6.2.i686.rpm
pidgin-devel pidgin-devel-2.7.9-5.el6.2.x86_64.rpm
pidgin-docs pidgin-docs-2.7.9-5.el6.2.i686.rpm
pidgin-docs pidgin-docs-2.7.9-5.el6.2.x86_64.rpm
pidgin-perl pidgin-perl-2.7.9-5.el6.2.i686.rpm
pidgin-perl pidgin-perl-2.7.9-5.el6.2.x86_64.rpm