Moderate CentOS libxml2 Update

Metadata

medium
4.3
libxml2-2.6.26-2.1.21.el5_9.1.i386.rpm, libxml2-2.6.26-2.1.21.el5_9.1.src.rpm, libxml2-2.6.26-2.1.21.el5_9.1.x86_64.rpm, libxml2-2.7.6-12.el6_4.1.i686.rpm, libxml2-2.7.6-12.el6_4.1.src.rpm, libxml2-2.7.6-12.el6_4.1.x86_64.rpm, libxml2-devel-2.6.26-2.1.21.el5_9.1.i386.rpm, libxml2-devel-2.6.26-2.1.21.el5_9.1.x86_64.rpm, libxml2-devel-2.7.6-12.el6_4.1.i686.rpm, libxml2-devel-2.7.6-12.el6_4.1.x86_64.rpm, libxml2-python-2.6.26-2.1.21.el5_9.1.i386.rpm, libxml2-python-2.6.26-2.1.21.el5_9.1.x86_64.rpm, libxml2-python-2.7.6-12.el6_4.1.i686.rpm, libxml2-python-2.7.6-12.el6_4.1.x86_64.rpm, libxml2-static-2.7.6-12.el6_4.1.i686.rpm, libxml2-static-2.7.6-12.el6_4.1.x86_64.rpm
CVE-2013-0338
rhn.redhat.com, lists.centos.org, lists.centos.org, lists.centos.org
2013-03-01
2017-07-27 19:05
ALAS-2013-188
CVE-2013-0338 libxml2
CVE-2013-0338
2017-04-01 19:06
2017-01-05 20:10

Description


Updated libxml2 packages that fix one security issue are now available for
Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

The libxml2 library is a development toolbox providing the implementation
of various XML standards.

A denial of service flaw was found in the way libxml2 performed string
substitutions when entity values for entity references replacement was
enabled. A remote attacker could provide a specially-crafted XML file that,
when processed by an application linked against libxml2, would lead to
excessive CPU consumption. (CVE-2013-0338)

All users of libxml2 are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue. The desktop must
be restarted (log out, then log back in) for this update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 libxml2 libxml2-2.6.26-2.1.21.el5_9.1.i386.rpm
libxml2 libxml2-2.6.26-2.1.21.el5_9.1.src.rpm
libxml2 libxml2-2.6.26-2.1.21.el5_9.1.x86_64.rpm
libxml2-devel libxml2-devel-2.6.26-2.1.21.el5_9.1.i386.rpm
libxml2-devel libxml2-devel-2.6.26-2.1.21.el5_9.1.x86_64.rpm
libxml2-python libxml2-python-2.6.26-2.1.21.el5_9.1.i386.rpm
libxml2-python libxml2-python-2.6.26-2.1.21.el5_9.1.x86_64.rpm
6 libxml2 libxml2-2.7.6-12.el6_4.1.i686.rpm
libxml2 libxml2-2.7.6-12.el6_4.1.src.rpm
libxml2 libxml2-2.7.6-12.el6_4.1.x86_64.rpm
libxml2-devel libxml2-devel-2.7.6-12.el6_4.1.i686.rpm
libxml2-devel libxml2-devel-2.7.6-12.el6_4.1.x86_64.rpm
libxml2-python libxml2-python-2.7.6-12.el6_4.1.i686.rpm
libxml2-python libxml2-python-2.7.6-12.el6_4.1.x86_64.rpm
libxml2-static libxml2-static-2.7.6-12.el6_4.1.i686.rpm
libxml2-static libxml2-static-2.7.6-12.el6_4.1.x86_64.rpm