Important CentOS hplip Update

Metadata

medium
6.9
hpijs-3.12.4-4.el6_4.1.i686.rpm, hpijs-3.12.4-4.el6_4.1.x86_64.rpm, hplip-3.12.4-4.el6_4.1.i686.rpm, hplip-3.12.4-4.el6_4.1.src.rpm, hplip-3.12.4-4.el6_4.1.x86_64.rpm, hplip-common-3.12.4-4.el6_4.1.i686.rpm, hplip-common-3.12.4-4.el6_4.1.x86_64.rpm, hplip-gui-3.12.4-4.el6_4.1.i686.rpm, hplip-gui-3.12.4-4.el6_4.1.x86_64.rpm, hplip-libs-3.12.4-4.el6_4.1.i686.rpm, hplip-libs-3.12.4-4.el6_4.1.x86_64.rpm, libsane-hpaio-3.12.4-4.el6_4.1.i686.rpm, libsane-hpaio-3.12.4-4.el6_4.1.x86_64.rpm
CVE-2013-4325
rhn.redhat.com, lists.centos.org
2013-09-20
2017-07-27 19:06
CVE-2013-4325 hplip
CVE-2013-4325
2017-04-01 19:07
2017-01-05 20:11

Description


Updated hplip packages that fix one security issue are now available for
Red Hat Enterprise Linux 6.

The Red Hat Security Response Team has rated this update as having
important security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from the
CVE link in the References section.

The hplip packages contain the Hewlett-Packard Linux Imaging and Printing
Project (HPLIP), which provides drivers for Hewlett-Packard printers and
multi-function peripherals.

HPLIP communicated with PolicyKit for authorization via a D-Bus API that is
vulnerable to a race condition. This could lead to intended PolicyKit
authorizations being bypassed. This update modifies HPLIP to communicate
with PolicyKit via a different API that is not vulnerable to the race
condition. (CVE-2013-4325)

All users of hplip are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 hpijs hpijs-3.12.4-4.el6_4.1.i686.rpm
hpijs hpijs-3.12.4-4.el6_4.1.x86_64.rpm
hplip hplip-3.12.4-4.el6_4.1.i686.rpm
hplip hplip-3.12.4-4.el6_4.1.src.rpm
hplip hplip-3.12.4-4.el6_4.1.x86_64.rpm
hplip-common hplip-common-3.12.4-4.el6_4.1.i686.rpm
hplip-common hplip-common-3.12.4-4.el6_4.1.x86_64.rpm
hplip-gui hplip-gui-3.12.4-4.el6_4.1.i686.rpm
hplip-gui hplip-gui-3.12.4-4.el6_4.1.x86_64.rpm
hplip-libs hplip-libs-3.12.4-4.el6_4.1.i686.rpm
hplip-libs hplip-libs-3.12.4-4.el6_4.1.x86_64.rpm
libsane-hpaio libsane-hpaio-3.12.4-4.el6_4.1.i686.rpm
libsane-hpaio libsane-hpaio-3.12.4-4.el6_4.1.x86_64.rpm