Moderate CentOS ibutils Update

Metadata

medium
6.3
ibutils-1.5.7-8.el6.i686.rpm, ibutils-1.5.7-8.el6.src.rpm, ibutils-1.5.7-8.el6.x86_64.rpm, ibutils-devel-1.5.7-8.el6.i686.rpm, ibutils-devel-1.5.7-8.el6.x86_64.rpm, ibutils-libs-1.5.7-8.el6.i686.rpm, ibutils-libs-1.5.7-8.el6.x86_64.rpm, infinipath-psm-3.0.1-115.1015_open.2.el6.src.rpm, infinipath-psm-3.0.1-115.1015_open.2.el6.x86_64.rpm, infinipath-psm-devel-3.0.1-115.1015_open.2.el6.x86_64.rpm, libibverbs-1.1.7-1.el6.i686.rpm, libibverbs-1.1.7-1.el6.src.rpm, libibverbs-1.1.7-1.el6.x86_64.rpm, libibverbs-devel-1.1.7-1.el6.i686.rpm, libibverbs-devel-1.1.7-1.el6.x86_64.rpm, libibverbs-devel-static-1.1.7-1.el6.i686.rpm, libibverbs-devel-static-1.1.7-1.el6.x86_64.rpm, libibverbs-utils-1.1.7-1.el6.i686.rpm, libibverbs-utils-1.1.7-1.el6.x86_64.rpm, libmlx4-1.0.5-4.el6.1.i686.rpm, libmlx4-1.0.5-4.el6.1.src.rpm, libmlx4-1.0.5-4.el6.1.x86_64.rpm, libmlx4-static-1.0.5-4.el6.1.i686.rpm, libmlx4-static-1.0.5-4.el6.1.x86_64.rpm, librdmacm-1.0.17-1.el6.i686.rpm, librdmacm-1.0.17-1.el6.src.rpm, librdmacm-1.0.17-1.el6.x86_64.rpm, librdmacm-devel-1.0.17-1.el6.i686.rpm, librdmacm-devel-1.0.17-1.el6.x86_64.rpm, librdmacm-static-1.0.17-1.el6.i686.rpm, librdmacm-static-1.0.17-1.el6.x86_64.rpm, librdmacm-utils-1.0.17-1.el6.i686.rpm, librdmacm-utils-1.0.17-1.el6.x86_64.rpm, mpitests-3.2-9.el6.src.rpm, mpitests-mvapich-3.2-9.el6.i686.rpm, mpitests-mvapich-3.2-9.el6.x86_64.rpm, mpitests-mvapich-psm-3.2-9.el6.x86_64.rpm, mpitests-mvapich2-3.2-9.el6.i686.rpm, mpitests-mvapich2-3.2-9.el6.x86_64.rpm, mpitests-mvapich2-psm-3.2-9.el6.x86_64.rpm, mpitests-openmpi-3.2-9.el6.i686.rpm, mpitests-openmpi-3.2-9.el6.x86_64.rpm, mstflint-3.0-0.6.g6961daa.1.el6.i686.rpm, mstflint-3.0-0.6.g6961daa.1.el6.src.rpm, mstflint-3.0-0.6.g6961daa.1.el6.x86_64.rpm, openmpi-1.5.4-2.el6.i686.rpm, openmpi-1.5.4-2.el6.src.rpm, openmpi-1.5.4-2.el6.x86_64.rpm, openmpi-devel-1.5.4-2.el6.i686.rpm, openmpi-devel-1.5.4-2.el6.x86_64.rpm, perftest-2.0-2.el6.i686.rpm, perftest-2.0-2.el6.src.rpm, perftest-2.0-2.el6.x86_64.rpm, qperf-0.4.9-1.el6.i686.rpm, qperf-0.4.9-1.el6.src.rpm, qperf-0.4.9-1.el6.x86_64.rpm, rdma-3.10-3.el6.noarch.rpm, rdma-3.10-3.el6.src.rpm
CVE-2012-4516, CVE-2013-2561
rhn.redhat.com, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org
2013-11-26
2017-07-27 19:06
ALAS-2013-256
CVE-2012-4516 librdmacm
CVE-2013-2561 ibutils
CVE-2013-2561
CVE-2012-4516
2017-04-01 19:07
2017-01-05 20:11

Description


Updated rdma, libibverbs, libmlx4, librdmacm, qperf, perftest, openmpi,
compat-openmpi, infinipath-psm, mpitests, and rds-tools packages that fix
two security issues, several bugs, and add various enhancements are now
available for Red Hat Enterprise Linux 6.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

Red Hat Enterprise Linux includes a collection of Infiniband and iWARP
utilities, libraries and development packages for writing applications that
use Remote Direct Memory Access (RDMA) technology.

A flaw was found in the way ibutils handled temporary files. A local
attacker could use this flaw to cause arbitrary files to be overwritten as
the root user via a symbolic link attack. (CVE-2013-2561)

It was discovered that librdmacm used a static port to connect to the
ib_acm service. A local attacker able to run a specially crafted ib_acm
service on that port could use this flaw to provide incorrect address
resolution information to librmdacm applications. (CVE-2012-4516)

The CVE-2012-4516 issue was discovered by Florian Weimer of the Red Hat
Product Security Team.

This advisory updates the following packages to the latest upstream
releases, providing a number of bug fixes and enhancements over the
previous versions:

* libibverbs-1.1.7
* libmlx4-1.0.5
* librdmacm-1.0.17
* mstflint-3.0
* perftest-2.0
* qperf-0.4.9
* rdma-3.10

Several bugs have been fixed in the openmpi, mpitests, ibutils, and
infinipath-psm packages.

The most notable changes in these updated packages from the RDMA stack are
the following:

* Multiple bugs in the Message Passing Interface (MPI) test packages were
resolved, allowing more of the mpitest applications to pass on the
underlying MPI implementations.

* The libmlx4 package now includes dracut module files to ensure that any
necessary custom configuration of mlx4 port types is included in the
initramfs dracut builds.

* Multiple test programs in the perftest and qperf packages now work
properly over RoCE interfaces, or when specifying the use of rdmacm
queue pairs.

* The mstflint package has been updated to the latest upstream version,
which is now capable of burning firmware on newly released Mellanox
Connect-IB hardware.

* A compatibility problem between the openmpi and infinipath-psm packages
has been resolved with new builds of these packages.

All RDMA users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues and add
these enhancements.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 ibutils ibutils-1.5.7-8.el6.i686.rpm
ibutils ibutils-1.5.7-8.el6.src.rpm
ibutils ibutils-1.5.7-8.el6.x86_64.rpm
ibutils-devel ibutils-devel-1.5.7-8.el6.i686.rpm
ibutils-devel ibutils-devel-1.5.7-8.el6.x86_64.rpm
ibutils-libs ibutils-libs-1.5.7-8.el6.i686.rpm
ibutils-libs ibutils-libs-1.5.7-8.el6.x86_64.rpm
infinipath-psm infinipath-psm-3.0.1-115.1015_open.2.el6.src.rpm
infinipath-psm infinipath-psm-3.0.1-115.1015_open.2.el6.x86_64.rpm
infinipath-psm-devel infinipath-psm-devel-3.0.1-115.1015_open.2.el6.x86_64.rpm
libibverbs libibverbs-1.1.7-1.el6.i686.rpm
libibverbs libibverbs-1.1.7-1.el6.src.rpm
libibverbs libibverbs-1.1.7-1.el6.x86_64.rpm
libibverbs-devel libibverbs-devel-1.1.7-1.el6.i686.rpm
libibverbs-devel libibverbs-devel-1.1.7-1.el6.x86_64.rpm
libibverbs-devel-static libibverbs-devel-static-1.1.7-1.el6.i686.rpm
libibverbs-devel-static libibverbs-devel-static-1.1.7-1.el6.x86_64.rpm
libibverbs-utils libibverbs-utils-1.1.7-1.el6.i686.rpm
libibverbs-utils libibverbs-utils-1.1.7-1.el6.x86_64.rpm
libmlx4 libmlx4-1.0.5-4.el6.1.i686.rpm
libmlx4 libmlx4-1.0.5-4.el6.1.src.rpm
libmlx4 libmlx4-1.0.5-4.el6.1.x86_64.rpm
libmlx4-static libmlx4-static-1.0.5-4.el6.1.i686.rpm
libmlx4-static libmlx4-static-1.0.5-4.el6.1.x86_64.rpm
librdmacm librdmacm-1.0.17-1.el6.i686.rpm
librdmacm librdmacm-1.0.17-1.el6.src.rpm
librdmacm librdmacm-1.0.17-1.el6.x86_64.rpm
librdmacm-devel librdmacm-devel-1.0.17-1.el6.i686.rpm
librdmacm-devel librdmacm-devel-1.0.17-1.el6.x86_64.rpm
librdmacm-static librdmacm-static-1.0.17-1.el6.i686.rpm
librdmacm-static librdmacm-static-1.0.17-1.el6.x86_64.rpm
librdmacm-utils librdmacm-utils-1.0.17-1.el6.x86_64.rpm
librdmacm-utils librdmacm-utils-1.0.17-1.el6.i686.rpm
mpitests mpitests-3.2-9.el6.src.rpm
mpitests-mvapich mpitests-mvapich-3.2-9.el6.i686.rpm
mpitests-mvapich mpitests-mvapich-3.2-9.el6.x86_64.rpm
mpitests-mvapich2 mpitests-mvapich2-3.2-9.el6.x86_64.rpm
mpitests-mvapich2 mpitests-mvapich2-3.2-9.el6.i686.rpm
mpitests-mvapich2-psm mpitests-mvapich2-psm-3.2-9.el6.x86_64.rpm
mpitests-mvapich-psm mpitests-mvapich-psm-3.2-9.el6.x86_64.rpm
mpitests-openmpi mpitests-openmpi-3.2-9.el6.i686.rpm
mpitests-openmpi mpitests-openmpi-3.2-9.el6.x86_64.rpm
mstflint mstflint-3.0-0.6.g6961daa.1.el6.x86_64.rpm
mstflint mstflint-3.0-0.6.g6961daa.1.el6.i686.rpm
mstflint mstflint-3.0-0.6.g6961daa.1.el6.src.rpm
openmpi openmpi-1.5.4-2.el6.i686.rpm
openmpi openmpi-1.5.4-2.el6.src.rpm
openmpi openmpi-1.5.4-2.el6.x86_64.rpm
openmpi-devel openmpi-devel-1.5.4-2.el6.i686.rpm
openmpi-devel openmpi-devel-1.5.4-2.el6.x86_64.rpm
perftest perftest-2.0-2.el6.i686.rpm
perftest perftest-2.0-2.el6.src.rpm
perftest perftest-2.0-2.el6.x86_64.rpm
qperf qperf-0.4.9-1.el6.i686.rpm
qperf qperf-0.4.9-1.el6.src.rpm
qperf qperf-0.4.9-1.el6.x86_64.rpm
rdma rdma-3.10-3.el6.noarch.rpm
rdma rdma-3.10-3.el6.src.rpm