Moderate CentOS samba3x Update

Metadata

low
3.3
libsmbclient-3.6.9-169.el6_5.i686.rpm, libsmbclient-3.6.9-169.el6_5.x86_64.rpm, libsmbclient-devel-3.6.9-169.el6_5.i686.rpm, libsmbclient-devel-3.6.9-169.el6_5.x86_64.rpm, samba-3.6.9-169.el6_5.i686.rpm, samba-3.6.9-169.el6_5.src.rpm, samba-3.6.9-169.el6_5.x86_64.rpm, samba-client-3.6.9-169.el6_5.i686.rpm, samba-client-3.6.9-169.el6_5.x86_64.rpm, samba-common-3.6.9-169.el6_5.i686.rpm, samba-common-3.6.9-169.el6_5.x86_64.rpm, samba-doc-3.6.9-169.el6_5.i686.rpm, samba-doc-3.6.9-169.el6_5.x86_64.rpm, samba-domainjoin-gui-3.6.9-169.el6_5.i686.rpm, samba-domainjoin-gui-3.6.9-169.el6_5.x86_64.rpm, samba-swat-3.6.9-169.el6_5.i686.rpm, samba-swat-3.6.9-169.el6_5.x86_64.rpm, samba-winbind-3.6.9-169.el6_5.i686.rpm, samba-winbind-3.6.9-169.el6_5.x86_64.rpm, samba-winbind-clients-3.6.9-169.el6_5.i686.rpm, samba-winbind-clients-3.6.9-169.el6_5.x86_64.rpm, samba-winbind-devel-3.6.9-169.el6_5.i686.rpm, samba-winbind-devel-3.6.9-169.el6_5.x86_64.rpm, samba-winbind-krb5-locator-3.6.9-169.el6_5.i686.rpm, samba-winbind-krb5-locator-3.6.9-169.el6_5.x86_64.rpm, samba3x-3.6.6-0.140.el5_10.i386.rpm, samba3x-3.6.6-0.140.el5_10.src.rpm, samba3x-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-client-3.6.6-0.140.el5_10.i386.rpm, samba3x-client-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-common-3.6.6-0.140.el5_10.i386.rpm, samba3x-common-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-doc-3.6.6-0.140.el5_10.i386.rpm, samba3x-doc-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-domainjoin-gui-3.6.6-0.140.el5_10.i386.rpm, samba3x-domainjoin-gui-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-swat-3.6.6-0.140.el5_10.i386.rpm, samba3x-swat-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-winbind-3.6.6-0.140.el5_10.i386.rpm, samba3x-winbind-3.6.6-0.140.el5_10.x86_64.rpm, samba3x-winbind-devel-3.6.6-0.140.el5_10.i386.rpm, samba3x-winbind-devel-3.6.6-0.140.el5_10.x86_64.rpm
CVE-2014-0244, CVE-2014-3493
rhn.redhat.com, lists.centos.org, lists.centos.org
2014-07-09
2017-07-27 19:07
Moderate CentOS samba Update
Important CentOS samba4 Update
CVE-2014-3493 samba4
CVE-2014-0244 samba
CVE-2014-3493 samba
CVE-2014-0244 samba4
CVE-2014-0244
CVE-2014-3493
2017-04-01 19:08
2017-01-05 20:12

Description


Updated samba3x and samba packages that fix two security issues are now
available for Red Hat Enterprise Linux 5 and 6 respectively.

The Red Hat Security Response Team has rated this update as having Moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

Samba is an open-source implementation of the Server Message Block (SMB) or
Common Internet File System (CIFS) protocol, which allows PC-compatible
machines to share files, printers, and other information.

A denial of service flaw was found in the way the sys_recvfile() function
of nmbd, the NetBIOS message block daemon, processed non-blocking sockets.
An attacker could send a specially crafted packet that, when processed,
would cause nmbd to enter an infinite loop and consume an excessive amount
of CPU time. (CVE-2014-0244)

It was discovered that smbd, the Samba file server daemon, did not properly
handle certain files that were stored on the disk and used a valid Unicode
character in the file name. An attacker able to send an authenticated
non-Unicode request that attempted to read such a file could cause smbd to
crash. (CVE-2014-3493)

Red Hat would like to thank Daniel Berteaud of FIREWALL-SERVICES SARL for
reporting CVE-2014-0244, and the Samba project for reporting CVE-2014-3493.
The Samba project acknowledges Simon Arlott as the original reporter of
CVE-2014-3493.

All Samba users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues. After installing this
update, the smb service will be restarted automatically.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 samba3x samba3x-3.6.6-0.140.el5_10.i386.rpm
samba3x samba3x-3.6.6-0.140.el5_10.src.rpm
samba3x samba3x-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-client samba3x-client-3.6.6-0.140.el5_10.i386.rpm
samba3x-client samba3x-client-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-common samba3x-common-3.6.6-0.140.el5_10.i386.rpm
samba3x-common samba3x-common-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-doc samba3x-doc-3.6.6-0.140.el5_10.i386.rpm
samba3x-doc samba3x-doc-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-domainjoin-gui samba3x-domainjoin-gui-3.6.6-0.140.el5_10.i386.rpm
samba3x-domainjoin-gui samba3x-domainjoin-gui-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-swat samba3x-swat-3.6.6-0.140.el5_10.i386.rpm
samba3x-swat samba3x-swat-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-winbind samba3x-winbind-3.6.6-0.140.el5_10.i386.rpm
samba3x-winbind samba3x-winbind-3.6.6-0.140.el5_10.x86_64.rpm
samba3x-winbind-devel samba3x-winbind-devel-3.6.6-0.140.el5_10.i386.rpm
samba3x-winbind-devel samba3x-winbind-devel-3.6.6-0.140.el5_10.x86_64.rpm
6 libsmbclient libsmbclient-3.6.9-169.el6_5.i686.rpm
libsmbclient libsmbclient-3.6.9-169.el6_5.x86_64.rpm
libsmbclient-devel libsmbclient-devel-3.6.9-169.el6_5.i686.rpm
libsmbclient-devel libsmbclient-devel-3.6.9-169.el6_5.x86_64.rpm
samba samba-3.6.9-169.el6_5.i686.rpm
samba samba-3.6.9-169.el6_5.src.rpm
samba samba-3.6.9-169.el6_5.x86_64.rpm
samba-client samba-client-3.6.9-169.el6_5.i686.rpm
samba-client samba-client-3.6.9-169.el6_5.x86_64.rpm
samba-common samba-common-3.6.9-169.el6_5.i686.rpm
samba-common samba-common-3.6.9-169.el6_5.x86_64.rpm
samba-doc samba-doc-3.6.9-169.el6_5.i686.rpm
samba-doc samba-doc-3.6.9-169.el6_5.x86_64.rpm
samba-domainjoin-gui samba-domainjoin-gui-3.6.9-169.el6_5.i686.rpm
samba-domainjoin-gui samba-domainjoin-gui-3.6.9-169.el6_5.x86_64.rpm
samba-swat samba-swat-3.6.9-169.el6_5.i686.rpm
samba-swat samba-swat-3.6.9-169.el6_5.x86_64.rpm
samba-winbind samba-winbind-3.6.9-169.el6_5.i686.rpm
samba-winbind samba-winbind-3.6.9-169.el6_5.x86_64.rpm
samba-winbind-clients samba-winbind-clients-3.6.9-169.el6_5.i686.rpm
samba-winbind-clients samba-winbind-clients-3.6.9-169.el6_5.x86_64.rpm
samba-winbind-devel samba-winbind-devel-3.6.9-169.el6_5.i686.rpm
samba-winbind-devel samba-winbind-devel-3.6.9-169.el6_5.x86_64.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-3.6.9-169.el6_5.i686.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-3.6.9-169.el6_5.x86_64.rpm