Moderate CentOS krb5 Security Update

Metadata

high
8.5
krb5-1.6.1-80.el5_11.src.rpm, krb5-devel-1.6.1-80.el5_11.i386.rpm, krb5-devel-1.6.1-80.el5_11.x86_64.rpm, krb5-libs-1.6.1-80.el5_11.i386.rpm, krb5-libs-1.6.1-80.el5_11.x86_64.rpm, krb5-server-1.6.1-80.el5_11.i386.rpm, krb5-server-1.6.1-80.el5_11.x86_64.rpm, krb5-server-ldap-1.6.1-80.el5_11.i386.rpm, krb5-server-ldap-1.6.1-80.el5_11.x86_64.rpm, krb5-workstation-1.6.1-80.el5_11.i386.rpm, krb5-workstation-1.6.1-80.el5_11.x86_64.rpm
CVE-2014-4345
rhn.redhat.com, lists.centos.org
2014-10-10
2017-07-27 19:07
ALAS-2014-443
Moderate CentOS krb5 Security Update
Moderate CentOS krb5 Security Update
CVE-2014-4345 krb5
CVE-2014-4345
2017-04-01 19:08
2017-01-05 20:12

Description


Updated krb5 packages that fix one security issue are now available for Red
Hat Enterprise Linux 5.

Red Hat Product Security has rated this update as having Moderate security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

Kerberos is an authentication system which allows clients and services to
authenticate to each other with the help of a trusted third party, a
Kerberos Key Distribution Center (KDC).

A buffer overflow was found in the KADM5 administration server (kadmind)
when it was used with an LDAP back end for the KDC database. A remote,
authenticated attacker could potentially use this flaw to execute arbitrary
code on the system running kadmind. (CVE-2014-4345)

All krb5 users are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue. After installing the
updated packages, the krb5kdc and kadmind daemons will be restarted
automatically.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 krb5 krb5-1.6.1-80.el5_11.src.rpm
krb5-devel krb5-devel-1.6.1-80.el5_11.i386.rpm
krb5-devel krb5-devel-1.6.1-80.el5_11.x86_64.rpm
krb5-libs krb5-libs-1.6.1-80.el5_11.i386.rpm
krb5-libs krb5-libs-1.6.1-80.el5_11.x86_64.rpm
krb5-server krb5-server-1.6.1-80.el5_11.i386.rpm
krb5-server krb5-server-1.6.1-80.el5_11.x86_64.rpm
krb5-server-ldap krb5-server-ldap-1.6.1-80.el5_11.i386.rpm
krb5-server-ldap krb5-server-ldap-1.6.1-80.el5_11.x86_64.rpm
krb5-workstation krb5-workstation-1.6.1-80.el5_11.i386.rpm
krb5-workstation krb5-workstation-1.6.1-80.el5_11.x86_64.rpm