Important CentOS openssl Security Update

Metadata

high
7.1
openssl-1.0.1e-30.el6_5.2.i686.rpm, openssl-1.0.1e-30.el6_5.2.src.rpm, openssl-1.0.1e-30.el6_5.2.x86_64.rpm, openssl-1.0.1e-30.el6_6.2.i686.rpm, openssl-1.0.1e-30.el6_6.2.src.rpm, openssl-1.0.1e-30.el6_6.2.x86_64.rpm, openssl-1.0.1e-34.el7_0.6.src.rpm, openssl-1.0.1e-34.el7_0.6.x86_64.rpm, openssl-devel-1.0.1e-30.el6_5.2.i686.rpm, openssl-devel-1.0.1e-30.el6_5.2.x86_64.rpm, openssl-devel-1.0.1e-30.el6_6.2.i686.rpm, openssl-devel-1.0.1e-30.el6_6.2.x86_64.rpm, openssl-devel-1.0.1e-34.el7_0.6.i686.rpm, openssl-devel-1.0.1e-34.el7_0.6.x86_64.rpm, openssl-libs-1.0.1e-34.el7_0.6.i686.rpm, openssl-libs-1.0.1e-34.el7_0.6.x86_64.rpm, openssl-perl-1.0.1e-30.el6_5.2.i686.rpm, openssl-perl-1.0.1e-30.el6_5.2.x86_64.rpm, openssl-perl-1.0.1e-30.el6_6.2.i686.rpm, openssl-perl-1.0.1e-30.el6_6.2.x86_64.rpm, openssl-perl-1.0.1e-34.el7_0.6.x86_64.rpm, openssl-static-1.0.1e-30.el6_5.2.i686.rpm, openssl-static-1.0.1e-30.el6_5.2.x86_64.rpm, openssl-static-1.0.1e-30.el6_6.2.i686.rpm, openssl-static-1.0.1e-30.el6_6.2.x86_64.rpm, openssl-static-1.0.1e-34.el7_0.6.i686.rpm, openssl-static-1.0.1e-34.el7_0.6.x86_64.rpm
CVE-2014-3513, CVE-2014-3567
rhn.redhat.com, lists.centos.org, lists.centos.org, lists.centos.org
2014-10-16
2017-07-27 19:07
ALAS-2014-427
CVE-2014-3567 openssl
CVE-2014-3513 openssl
CVE-2014-3513
CVE-2014-3567
2017-04-01 19:08
2017-01-05 20:12

Description


Updated openssl packages that contain a backported patch to mitigate the
CVE-2014-3566 issue and fix two security issues are now available for Red
Hat Enterprise Linux 6 and 7.

Red Hat Product Security has rated this update as having Important security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

OpenSSL is a toolkit that implements the Secure Sockets Layer (SSL),
Transport Layer Security (TLS), and Datagram Transport Layer Security
(DTLS) protocols, as well as a full-strength, general purpose cryptography
library.

This update adds support for the TLS Fallback Signaling Cipher Suite Value
(TLS_FALLBACK_SCSV), which can be used to prevent protocol downgrade
attacks against applications which re-connect using a lower SSL/TLS
protocol version when the initial connection indicating the highest
supported protocol version fails.

This can prevent a forceful downgrade of the communication to SSL 3.0.
The SSL 3.0 protocol was found to be vulnerable to the padding oracle
attack when using block cipher suites in cipher block chaining (CBC) mode.
This issue is identified as CVE-2014-3566, and also known under the alias
POODLE. This SSL 3.0 protocol flaw will not be addressed in a future
update; it is recommended that users configure their applications to
require at least TLS protocol version 1.0 for secure communication.

For additional information about this flaw, see the Knowledgebase article
at https://access.redhat.com/articles/1232123

A memory leak flaw was found in the way OpenSSL parsed the DTLS Secure
Real-time Transport Protocol (SRTP) extension data. A remote attacker could
send multiple specially crafted handshake messages to exhaust all available
memory of an SSL/TLS or DTLS server. (CVE-2014-3513)

A memory leak flaw was found in the way an OpenSSL handled failed session
ticket integrity checks. A remote attacker could exhaust all available
memory of an SSL/TLS or DTLS server by sending a large number of invalid
session tickets to that server. (CVE-2014-3567)

All OpenSSL users are advised to upgrade to these updated packages, which
contain backported patches to mitigate the CVE-2014-3566 issue and correct
the CVE-2014-3513 and CVE-2014-3567 issues. For the update to take effect,
all services linked to the OpenSSL library (such as httpd and other
SSL-enabled services) must be restarted or the system rebooted.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 openssl openssl-1.0.1e-30.el6_5.2.src.rpm
openssl openssl-1.0.1e-30.el6_5.2.i686.rpm
openssl openssl-1.0.1e-30.el6_5.2.x86_64.rpm
openssl openssl-1.0.1e-30.el6_6.2.i686.rpm
openssl openssl-1.0.1e-30.el6_6.2.src.rpm
openssl openssl-1.0.1e-30.el6_6.2.x86_64.rpm
openssl-devel openssl-devel-1.0.1e-30.el6_5.2.x86_64.rpm
openssl-devel openssl-devel-1.0.1e-30.el6_6.2.x86_64.rpm
openssl-devel openssl-devel-1.0.1e-30.el6_5.2.i686.rpm
openssl-devel openssl-devel-1.0.1e-30.el6_6.2.i686.rpm
openssl-perl openssl-perl-1.0.1e-30.el6_6.2.x86_64.rpm
openssl-perl openssl-perl-1.0.1e-30.el6_5.2.i686.rpm
openssl-perl openssl-perl-1.0.1e-30.el6_5.2.x86_64.rpm
openssl-perl openssl-perl-1.0.1e-30.el6_6.2.i686.rpm
openssl-static openssl-static-1.0.1e-30.el6_6.2.x86_64.rpm
openssl-static openssl-static-1.0.1e-30.el6_6.2.i686.rpm
openssl-static openssl-static-1.0.1e-30.el6_5.2.x86_64.rpm
openssl-static openssl-static-1.0.1e-30.el6_5.2.i686.rpm
7 openssl openssl-1.0.1e-34.el7_0.6.x86_64.rpm
openssl openssl-1.0.1e-34.el7_0.6.src.rpm
openssl-devel openssl-devel-1.0.1e-34.el7_0.6.x86_64.rpm
openssl-devel openssl-devel-1.0.1e-34.el7_0.6.i686.rpm
openssl-libs openssl-libs-1.0.1e-34.el7_0.6.x86_64.rpm
openssl-libs openssl-libs-1.0.1e-34.el7_0.6.i686.rpm
openssl-perl openssl-perl-1.0.1e-34.el7_0.6.x86_64.rpm
openssl-static openssl-static-1.0.1e-34.el7_0.6.i686.rpm
openssl-static openssl-static-1.0.1e-34.el7_0.6.x86_64.rpm