Moderate CentOS openssl Security Update


openssl-0.9.8e-31.el5_11.i386.rpm, openssl-0.9.8e-31.el5_11.i686.rpm, openssl-0.9.8e-31.el5_11.src.rpm, openssl-0.9.8e-31.el5_11.x86_64.rpm, openssl-devel-0.9.8e-31.el5_11.i386.rpm, openssl-devel-0.9.8e-31.el5_11.x86_64.rpm, openssl-perl-0.9.8e-31.el5_11.i386.rpm, openssl-perl-0.9.8e-31.el5_11.x86_64.rpm,,
2017-07-27 19:07
2017-04-01 19:08
2017-01-05 20:12


Updated openssl packages that contain a backported patch to mitigate the
CVE-2014-3566 issue are now available for Red Hat Enterprise Linux 5.

Red Hat Product Security has rated this update as having Moderate security

OpenSSL is a toolkit that implements the Secure Sockets Layer (SSL),
Transport Layer Security (TLS), and Datagram Transport Layer Security
(DTLS) protocols, as well as a full-strength, general purpose cryptography

This update adds support for the TLS Fallback Signaling Cipher Suite Value
(TLS_FALLBACK_SCSV), which can be used to prevent protocol downgrade
attacks against applications which re-connect using a lower SSL/TLS
protocol version when the initial connection indicating the highest
supported protocol version fails.

This can prevent a forceful downgrade of the communication to SSL 3.0.
The SSL 3.0 protocol was found to be vulnerable to the padding oracle
attack when using block cipher suites in cipher block chaining (CBC) mode.
This issue is identified as CVE-2014-3566, and also known under the alias
POODLE. This SSL 3.0 protocol flaw will not be addressed in a future
update; it is recommended that users configure their applications to
require at least TLS protocol version 1.0 for secure communication.

For additional information about this flaw, see the Knowledgebase article

All OpenSSL users are advised to upgrade to these updated packages, which
contain a backported patch to mitigate the CVE-2014-3566 issue. For the
update to take effect, all services linked to the OpenSSL library (such as
httpd and other SSL-enabled services) must be restarted or the system
Please see

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 openssl openssl-0.9.8e-31.el5_11.i386.rpm
openssl openssl-0.9.8e-31.el5_11.i686.rpm
openssl openssl-0.9.8e-31.el5_11.src.rpm
openssl openssl-0.9.8e-31.el5_11.x86_64.rpm
openssl-devel openssl-devel-0.9.8e-31.el5_11.i386.rpm
openssl-devel openssl-devel-0.9.8e-31.el5_11.x86_64.rpm
openssl-perl openssl-perl-0.9.8e-31.el5_11.i386.rpm
openssl-perl openssl-perl-0.9.8e-31.el5_11.x86_64.rpm