Important CentOS samba Security Update

Metadata

critical
10.0
libsmbclient-4.1.1-38.el7_0.i686.rpm, libsmbclient-4.1.1-38.el7_0.x86_64.rpm, libsmbclient-devel-4.1.1-38.el7_0.i686.rpm, libsmbclient-devel-4.1.1-38.el7_0.x86_64.rpm, libwbclient-4.1.1-38.el7_0.i686.rpm, libwbclient-4.1.1-38.el7_0.x86_64.rpm, libwbclient-devel-4.1.1-38.el7_0.i686.rpm, libwbclient-devel-4.1.1-38.el7_0.x86_64.rpm, samba-4.1.1-38.el7_0.src.rpm, samba-4.1.1-38.el7_0.x86_64.rpm, samba-client-4.1.1-38.el7_0.x86_64.rpm, samba-common-4.1.1-38.el7_0.x86_64.rpm, samba-dc-4.1.1-38.el7_0.x86_64.rpm, samba-dc-libs-4.1.1-38.el7_0.x86_64.rpm, samba-devel-4.1.1-38.el7_0.i686.rpm, samba-devel-4.1.1-38.el7_0.x86_64.rpm, samba-libs-4.1.1-38.el7_0.i686.rpm, samba-libs-4.1.1-38.el7_0.x86_64.rpm, samba-pidl-4.1.1-38.el7_0.x86_64.rpm, samba-python-4.1.1-38.el7_0.x86_64.rpm, samba-test-4.1.1-38.el7_0.x86_64.rpm, samba-test-devel-4.1.1-38.el7_0.x86_64.rpm, samba-vfs-glusterfs-4.1.1-38.el7_0.x86_64.rpm, samba-winbind-4.1.1-38.el7_0.x86_64.rpm, samba-winbind-clients-4.1.1-38.el7_0.x86_64.rpm, samba-winbind-krb5-locator-4.1.1-38.el7_0.x86_64.rpm, samba-winbind-modules-4.1.1-38.el7_0.i686.rpm, samba-winbind-modules-4.1.1-38.el7_0.x86_64.rpm
CVE-2015-0240
rhn.redhat.com, lists.centos.org
2015-02-23
2017-07-27 19:08
Critical CentOS samba Security Update
Critical CentOS samba4 Security Update
Critical CentOS samba3x Security Update
CVE-2015-0240 samba
CVE-2015-0240 samba4
CVE-2015-0240
2017-04-01 19:08
2017-01-05 20:12

Description


Updated samba packages that fix one security issue are now available for
Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having Important security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

Samba is an open-source implementation of the Server Message Block (SMB) or
Common Internet File System (CIFS) protocol, which allows PC-compatible
machines to share files, printers, and other information.

An uninitialized pointer use flaw was found in the Samba daemon (smbd).
A malicious Samba client could send specially crafted netlogon packets
that, when processed by smbd, could potentially lead to arbitrary code
execution with the privileges of the user running smbd (by default, the
root user). (CVE-2015-0240)

For additional information about this flaw, see the Knowledgebase article
at https://access.redhat.com/articles/1346913

Red Hat would like to thank the Samba project for reporting this issue.
Upstream acknowledges Richard van Eeden of Microsoft Vulnerability Research
as the original reporter of this issue.

All Samba users are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue. After installing this
update, the smb service will be restarted automatically.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
7 libsmbclient libsmbclient-4.1.1-38.el7_0.i686.rpm
libsmbclient libsmbclient-4.1.1-38.el7_0.x86_64.rpm
libsmbclient-devel libsmbclient-devel-4.1.1-38.el7_0.i686.rpm
libsmbclient-devel libsmbclient-devel-4.1.1-38.el7_0.x86_64.rpm
libwbclient libwbclient-4.1.1-38.el7_0.i686.rpm
libwbclient libwbclient-4.1.1-38.el7_0.x86_64.rpm
libwbclient-devel libwbclient-devel-4.1.1-38.el7_0.i686.rpm
libwbclient-devel libwbclient-devel-4.1.1-38.el7_0.x86_64.rpm
samba samba-4.1.1-38.el7_0.src.rpm
samba samba-4.1.1-38.el7_0.x86_64.rpm
samba-client samba-client-4.1.1-38.el7_0.x86_64.rpm
samba-common samba-common-4.1.1-38.el7_0.x86_64.rpm
samba-dc samba-dc-4.1.1-38.el7_0.x86_64.rpm
samba-dc-libs samba-dc-libs-4.1.1-38.el7_0.x86_64.rpm
samba-devel samba-devel-4.1.1-38.el7_0.i686.rpm
samba-devel samba-devel-4.1.1-38.el7_0.x86_64.rpm
samba-libs samba-libs-4.1.1-38.el7_0.i686.rpm
samba-libs samba-libs-4.1.1-38.el7_0.x86_64.rpm
samba-pidl samba-pidl-4.1.1-38.el7_0.x86_64.rpm
samba-python samba-python-4.1.1-38.el7_0.x86_64.rpm
samba-test samba-test-4.1.1-38.el7_0.x86_64.rpm
samba-test-devel samba-test-devel-4.1.1-38.el7_0.x86_64.rpm
samba-vfs-glusterfs samba-vfs-glusterfs-4.1.1-38.el7_0.x86_64.rpm
samba-winbind samba-winbind-4.1.1-38.el7_0.x86_64.rpm
samba-winbind-clients samba-winbind-clients-4.1.1-38.el7_0.x86_64.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-4.1.1-38.el7_0.x86_64.rpm
samba-winbind-modules samba-winbind-modules-4.1.1-38.el7_0.i686.rpm
samba-winbind-modules samba-winbind-modules-4.1.1-38.el7_0.x86_64.rpm