Low CentOS clutter Security Update

Metadata

high
7.2
clutter-1.14.4-12.el7.i686.rpm, clutter-1.14.4-12.el7.x86_64.rpm, clutter-devel-1.14.4-12.el7.i686.rpm, clutter-devel-1.14.4-12.el7.x86_64.rpm, clutter-doc-1.14.4-12.el7.x86_64.rpm, cogl-1.14.0-6.el7.i686.rpm, cogl-1.14.0-6.el7.x86_64.rpm, cogl-devel-1.14.0-6.el7.i686.rpm, cogl-devel-1.14.0-6.el7.x86_64.rpm, cogl-doc-1.14.0-6.el7.noarch.rpm, gnome-shell-3.8.4-45.el7.x86_64.rpm, gnome-shell-browser-plugin-3.8.4-45.el7.x86_64.rpm, mutter-3.8.4-16.el7.i686.rpm, mutter-3.8.4-16.el7.x86_64.rpm, mutter-devel-3.8.4-16.el7.i686.rpm, mutter-devel-3.8.4-16.el7.x86_64.rpm
CVE-2014-7300
rhn.redhat.com, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org
2015-03-17
2017-07-27 19:08
CVE-2014-7300 gnome-shell
CVE-2014-7300
2017-04-01 19:08
2017-01-05 20:12

Description


Updated gnome-shell, mutter, clutter, and cogl packages that fix one security issue, several bugs, and add one enhancement are now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having Low security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

GNOME Shell and the packages it depends upon provide the core user interface of the Red Hat Enterprise Linux desktop, including functions such as navigating between windows and launching applications.

It was found that the GNOME shell did not disable the Print Screen key when the screen was locked. This could allow an attacker with physical access to a system with a locked screen to crash the screen-locking application by creating a large amount of screenshots. (CVE-2014-7300)

This update also fixes the following bugs:

* The Timed Login feature, which automatically logs in a specified user after a specified period of time, stopped working after the first user of the GUI logged out. This has been fixed, and the specified user is always logged in if no one else logs in. (BZ#1043571)

* If two monitors were arranged vertically with the secondary monitor above the primary monitor, it was impossible to move windows onto the secondary monitor. With this update, windows can be moved through the upper edge of the first monitor to the secondary monitor. (BZ#1075240)

* If the Gnome Display Manager (GDM) user list was disabled and a user entered the user name, the password prompt did not appear. Instead, the user had to enter the user name one more time. The GDM code that contained this error has been fixed, and users can enter their user names and passwords as expected. (BZ#1109530)

* Prior to this update, only a small area was available on the GDM login screen for a custom text banner. As a consequence, when a long banner was used, it did not fit into the area, and the person reading the banner had to use scrollbars to view the whole text. With this update, more space is used for the banner if necessary, which allows the user to read the message conveniently. (BZ#1110036)

* When the Cancel button was pressed while an LDAP user name and password was being validated, the GDM code did not handle the situation correctly. As a consequence, GDM became unresponsive, and it was impossible to return to the login screen. The affected code has been fixed, and LDAP user validation can be canceled, allowing another user to log in instead. (BZ#1137041)

* If the window focus mode in GNOME was set to "mouse" or "sloppy", navigating through areas of a pop-up menu displayed outside its parent window caused the window to lose its focus. Consequently, the menu was not usable. This has been fixed, and the window focus is kept in under this scenario. (BZ#1149585)

* If user authentication is configured to require a smart card to log in, user names are obtained from the smart card. The authentication is then performed by entering the smart card PIN. Prior to this update, the login screen allowed a user name to be entered if no smart card was inserted, but due to a bug in the underlying code, the screen became unresponsive. If, on the other hand, a smart card was used for authentication, the user was logged in as soon as the authentication was complete. As a consequence, it was impossible to select a session other than GNOME Classic. Both of these problems have been fixed. Now, a smart card is required when this type of authentication is enabled, and any other installed session can be selected by the user. (BZ#1159385, BZ#1163474)

In addition, this update adds the following enhancement:

* Support for quad-buffer OpenGL stereo visuals has been added. As a result, OpenGL applications that use quad-buffer stereo can be run and properly displayed within the GNOME desktop when used with a video driver and hardware with the necessary capabilities. (BZ#861507, BZ#1108890, BZ#1108891, BZ#1108893)

All GNOME Shell users are advised to upgrade to these updated packages, which contain backported patches to correct these issues and add this enhancement.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
7 clutter clutter-1.14.4-12.el7.i686.rpm
clutter clutter-1.14.4-12.el7.x86_64.rpm
clutter-devel clutter-devel-1.14.4-12.el7.i686.rpm
clutter-devel clutter-devel-1.14.4-12.el7.x86_64.rpm
clutter-doc clutter-doc-1.14.4-12.el7.x86_64.rpm
cogl cogl-1.14.0-6.el7.i686.rpm
cogl cogl-1.14.0-6.el7.x86_64.rpm
cogl-devel cogl-devel-1.14.0-6.el7.i686.rpm
cogl-devel cogl-devel-1.14.0-6.el7.x86_64.rpm
cogl-doc cogl-doc-1.14.0-6.el7.noarch.rpm
gnome-shell gnome-shell-3.8.4-45.el7.x86_64.rpm
gnome-shell-browser-plugin gnome-shell-browser-plugin-3.8.4-45.el7.x86_64.rpm
mutter mutter-3.8.4-16.el7.i686.rpm
mutter mutter-3.8.4-16.el7.x86_64.rpm
mutter-devel mutter-devel-3.8.4-16.el7.i686.rpm
mutter-devel mutter-devel-3.8.4-16.el7.x86_64.rpm