Moderate CentOS nss-util Security Update

Metadata

medium
4.3
nss-3.19.1-3.el6_6.i686.rpm, nss-3.19.1-3.el6_6.src.rpm, nss-3.19.1-3.el6_6.x86_64.rpm, nss-3.19.1-3.el7_1.i686.rpm, nss-3.19.1-3.el7_1.src.rpm, nss-3.19.1-3.el7_1.x86_64.rpm, nss-devel-3.19.1-3.el6_6.i686.rpm, nss-devel-3.19.1-3.el6_6.x86_64.rpm, nss-devel-3.19.1-3.el7_1.i686.rpm, nss-devel-3.19.1-3.el7_1.x86_64.rpm, nss-pkcs11-devel-3.19.1-3.el6_6.i686.rpm, nss-pkcs11-devel-3.19.1-3.el6_6.x86_64.rpm, nss-pkcs11-devel-3.19.1-3.el7_1.i686.rpm, nss-pkcs11-devel-3.19.1-3.el7_1.x86_64.rpm, nss-sysinit-3.19.1-3.el6_6.i686.rpm, nss-sysinit-3.19.1-3.el6_6.x86_64.rpm, nss-sysinit-3.19.1-3.el7_1.x86_64.rpm, nss-tools-3.19.1-3.el6_6.i686.rpm, nss-tools-3.19.1-3.el6_6.x86_64.rpm, nss-tools-3.19.1-3.el7_1.x86_64.rpm, nss-util-3.19.1-1.el6_6.i686.rpm, nss-util-3.19.1-1.el6_6.src.rpm, nss-util-3.19.1-1.el6_6.x86_64.rpm, nss-util-3.19.1-1.el7_1.i686.rpm, nss-util-3.19.1-1.el7_1.src.rpm, nss-util-3.19.1-1.el7_1.x86_64.rpm, nss-util-devel-3.19.1-1.el6_6.i686.rpm, nss-util-devel-3.19.1-1.el6_6.x86_64.rpm, nss-util-devel-3.19.1-1.el7_1.i686.rpm, nss-util-devel-3.19.1-1.el7_1.x86_64.rpm
CVE-2015-2721, CVE-2015-4000
rhn.redhat.com, lists.centos.org, lists.centos.org, lists.centos.org, lists.centos.org
2015-06-25
2017-07-27 19:09
ALAS-2015-550
ALAS-2015-586
ALAS-2015-569
ALAS-2015-571
ALAS-2015-570
Important CentOS java-1.6.0-openjdk Security Update
Moderate CentOS openssl Security Update
Important CentOS java-1.7.0-openjdk Security Update
Moderate CentOS nss Security Update
Moderate CentOS openssl Security Update
Important CentOS java-1.8.0-openjdk Security Update
Critical CentOS java-1.7.0-openjdk Security Update
CVE-2015-4000 openssl
CVE-2015-4000 openjdk-8
CVE-2015-2721 icedove
CVE-2015-2721 nss
CVE-2015-2721 iceweasel
CVE-2015-4000 openjdk-7
CVE-2015-4000 icedove
CVE-2015-4000 nss
CVE-2015-4000 openjdk-6
CVE-2015-4000 iceweasel
CVE-2015-4000
CVE-2015-2721
2017-04-01 19:09
2017-01-05 20:13

Description


Updated nss and nss-util packages that fix one security issue, several bugs
and add various enhancements are now available for Red Hat Enterprise Linux
6 and 7.

Red Hat Product Security has rated this update as having Moderate security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

Network Security Services (NSS) is a set of libraries designed to support
cross-platform development of security-enabled client and server
applications.

A flaw was found in the way the TLS protocol composes the Diffie-Hellman
(DH) key exchange. A man-in-the-middle attacker could use this flaw to
force the use of weak 512 bit export-grade keys during the key exchange,
allowing them do decrypt all traffic. (CVE-2015-4000)

Note: This update forces the TLS/SSL client implementation in NSS to
reject DH key sizes below 768 bits, which prevents sessions to be
downgraded to export-grade keys. Future updates may raise this limit to
1024 bits.

The nss and nss-util packages have been upgraded to upstream versions
3.19.1. The upgraded versions provide a number of bug fixes and
enhancements over the previous versions.

Users of nss and nss-util are advised to upgrade to these updated packages,
which fix these security flaws, bugs, and add these enhancements.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 nss nss-3.19.1-3.el6_6.src.rpm
nss nss-3.19.1-3.el6_6.i686.rpm
nss nss-3.19.1-3.el6_6.x86_64.rpm
nss-devel nss-devel-3.19.1-3.el6_6.i686.rpm
nss-devel nss-devel-3.19.1-3.el6_6.x86_64.rpm
nss-pkcs11-devel nss-pkcs11-devel-3.19.1-3.el6_6.x86_64.rpm
nss-pkcs11-devel nss-pkcs11-devel-3.19.1-3.el6_6.i686.rpm
nss-sysinit nss-sysinit-3.19.1-3.el6_6.x86_64.rpm
nss-sysinit nss-sysinit-3.19.1-3.el6_6.i686.rpm
nss-tools nss-tools-3.19.1-3.el6_6.i686.rpm
nss-tools nss-tools-3.19.1-3.el6_6.x86_64.rpm
nss-util nss-util-3.19.1-1.el6_6.x86_64.rpm
nss-util nss-util-3.19.1-1.el6_6.i686.rpm
nss-util nss-util-3.19.1-1.el6_6.src.rpm
nss-util-devel nss-util-devel-3.19.1-1.el6_6.i686.rpm
nss-util-devel nss-util-devel-3.19.1-1.el6_6.x86_64.rpm
7 nss nss-3.19.1-3.el7_1.x86_64.rpm
nss nss-3.19.1-3.el7_1.i686.rpm
nss nss-3.19.1-3.el7_1.src.rpm
nss-devel nss-devel-3.19.1-3.el7_1.i686.rpm
nss-devel nss-devel-3.19.1-3.el7_1.x86_64.rpm
nss-pkcs11-devel nss-pkcs11-devel-3.19.1-3.el7_1.x86_64.rpm
nss-pkcs11-devel nss-pkcs11-devel-3.19.1-3.el7_1.i686.rpm
nss-sysinit nss-sysinit-3.19.1-3.el7_1.x86_64.rpm
nss-tools nss-tools-3.19.1-3.el7_1.x86_64.rpm
nss-util nss-util-3.19.1-1.el7_1.x86_64.rpm
nss-util nss-util-3.19.1-1.el7_1.i686.rpm
nss-util nss-util-3.19.1-1.el7_1.src.rpm
nss-util-devel nss-util-devel-3.19.1-1.el7_1.i686.rpm
nss-util-devel nss-util-devel-3.19.1-1.el7_1.x86_64.rpm