Important CentOS java-1.8.0-openjdk Security Update

Metadata

critical
10.0
java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.src.rpm, java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-1.8.0.65-2.b17.el7_1.src.rpm, java-1.8.0-openjdk-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-accessibility-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-debug-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-demo-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-demo-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-demo-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-demo-debug-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-demo-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-devel-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-devel-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-devel-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-devel-debug-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-devel-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-headless-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-headless-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-headless-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-headless-debug-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-headless-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-javadoc-1.8.0.65-0.b17.el6_7.noarch.rpm, java-1.8.0-openjdk-javadoc-1.8.0.65-2.b17.el7_1.noarch.rpm, java-1.8.0-openjdk-javadoc-debug-1.8.0.65-0.b17.el6_7.noarch.rpm, java-1.8.0-openjdk-src-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-src-1.8.0.65-0.b17.el6_7.x86_64.rpm, java-1.8.0-openjdk-src-1.8.0.65-2.b17.el7_1.x86_64.rpm, java-1.8.0-openjdk-src-debug-1.8.0.65-0.b17.el6_7.i686.rpm, java-1.8.0-openjdk-src-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
CVE-2015-4734, CVE-2015-4803, CVE-2015-4805, CVE-2015-4806, CVE-2015-4835, CVE-2015-4840, CVE-2015-4842, CVE-2015-4843, CVE-2015-4844, CVE-2015-4860, CVE-2015-4868, CVE-2015-4872, CVE-2015-4881, CVE-2015-4882, CVE-2015-4883, CVE-2015-4893, CVE-2015-4903, CVE-2015-4911
rhn.redhat.com, lists.centos.org, lists.centos.org
2015-10-21
2017-07-27 19:09
ALAS-2015-616
ALAS-2015-606
ALAS-2015-605
Important CentOS java-1.7.0-openjdk Security Update
Critical CentOS java-1.7.0-openjdk Security Update
Important CentOS java-1.6.0-openjdk Security Update
CVE-2015-4835 openjdk-6
CVE-2015-4911 openjdk-6
CVE-2015-4805 openjdk-6
CVE-2015-4806 openjdk-8
CVE-2015-4844 icu
CVE-2015-4805 openjdk-7
CVE-2015-4843 openjdk-6
CVE-2015-4860 openjdk-6
CVE-2015-4881 openjdk-6
CVE-2015-4883 openjdk-6
CVE-2015-4883 openjdk-8
CVE-2015-4734 openjdk-7
CVE-2015-4734 openjdk-8
CVE-2015-4911 openjdk-7
CVE-2015-4868 openjdk-8
CVE-2015-4842 openjdk-6
CVE-2015-4882 openjdk-7
CVE-2015-4835 openjdk-7
CVE-2015-4883 openjdk-7
CVE-2015-4842 openjdk-7
CVE-2015-4844 openjdk-7
CVE-2015-4734 openjdk-6
CVE-2015-4903 openjdk-6
CVE-2015-4844 openjdk-6
CVE-2015-4806 openjdk-6
CVE-2015-4903 openjdk-7
CVE-2015-4881 openjdk-7
CVE-2015-4840 openjdk-7
CVE-2015-4860 openjdk-7
CVE-2015-4803 openjdk-8
CVE-2015-4803 openjdk-6
CVE-2015-4872 openjdk-8
CVE-2015-4872 openjdk-6
CVE-2015-4872 openjdk-7
CVE-2015-4843 openjdk-7
CVE-2015-4911 openjdk-8
CVE-2015-4805 openjdk-8
CVE-2015-4893 openjdk-7
CVE-2015-4806 openjdk-7
CVE-2015-4893 openjdk-6
CVE-2015-4882 openjdk-6
CVE-2015-4860 openjdk-8
CVE-2015-4842 openjdk-8
CVE-2015-4844 openjdk-8
CVE-2015-4903 openjdk-8
CVE-2015-4840 openjdk-8
CVE-2015-4882 openjdk-8
CVE-2015-4881 openjdk-8
CVE-2015-4835 openjdk-8
CVE-2015-4843 openjdk-8
CVE-2015-4893 openjdk-8
CVE-2015-4803 openjdk-7
CVE-2015-4835
CVE-2015-4893
CVE-2015-4911
CVE-2015-4843
CVE-2015-4882
CVE-2015-4844
CVE-2015-4883
CVE-2015-4840
CVE-2015-4734
CVE-2015-4805
CVE-2015-4868
CVE-2015-4803
CVE-2015-4842
CVE-2015-4860
CVE-2015-4881
CVE-2015-4872
CVE-2015-4903
CVE-2015-4806
2017-04-01 19:09
2017-01-05 20:13

Description


Updated java-1.8.0-openjdk packages that fix multiple security issues are
now available for Red Hat Enterprise Linux 6 and 7.

Red Hat Product Security has rated this update as having Important security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

The java-1.8.0-openjdk packages provide the OpenJDK 8 Java Runtime
Environment and the OpenJDK 8 Java Software Development Kit.

Multiple flaws were discovered in the CORBA, Libraries, RMI, Serialization,
and 2D components in OpenJDK. An untrusted Java application or applet could
use these flaws to completely bypass Java sandbox restrictions.
(CVE-2015-4835, CVE-2015-4881, CVE-2015-4843, CVE-2015-4883, CVE-2015-4860,
CVE-2015-4805, CVE-2015-4844)

Multiple denial of service flaws were found in the JAXP component in
OpenJDK. A specially crafted XML file could cause a Java application using
JAXP to consume an excessive amount of CPU and memory when parsed.
(CVE-2015-4803, CVE-2015-4893, CVE-2015-4911)

A flaw was found in the way the Libraries component in OpenJDK handled
certificate revocation lists (CRL). In certain cases, CRL checking code
could fail to report a revoked certificate, causing the application to
accept it as trusted. (CVE-2015-4868)

It was discovered that the Security component in OpenJDK failed to properly
check if a certificate satisfied all defined constraints. In certain cases,
this could cause a Java application to accept an X.509 certificate which
does not meet requirements of the defined policy. (CVE-2015-4872)

Multiple flaws were found in the Libraries, 2D, CORBA, JAXP, JGSS, and RMI
components in OpenJDK. An untrusted Java application or applet could use
these flaws to bypass certain Java sandbox restrictions. (CVE-2015-4806,
CVE-2015-4840, CVE-2015-4882, CVE-2015-4842, CVE-2015-4734, CVE-2015-4903)

Red Hat would like to thank Andrea Palazzo of Truel IT for reporting the
CVE-2015-4806 issue.

All users of java-1.8.0-openjdk are advised to upgrade to these updated
packages, which resolve these issues. All running instances of OpenJDK Java
must be restarted for the update to take effect.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 java-1.8.0-openjdk java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.src.rpm
java-1.8.0-openjdk java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk java-1.8.0-openjdk-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-debug java-1.8.0-openjdk-debug-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-debug java-1.8.0-openjdk-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-demo java-1.8.0-openjdk-demo-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-demo java-1.8.0-openjdk-demo-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-demo-debug java-1.8.0-openjdk-demo-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-demo-debug java-1.8.0-openjdk-demo-debug-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-devel java-1.8.0-openjdk-devel-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-devel java-1.8.0-openjdk-devel-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-devel-debug java-1.8.0-openjdk-devel-debug-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-devel-debug java-1.8.0-openjdk-devel-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-headless java-1.8.0-openjdk-headless-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-headless java-1.8.0-openjdk-headless-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-headless-debug java-1.8.0-openjdk-headless-debug-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-headless-debug java-1.8.0-openjdk-headless-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-javadoc java-1.8.0-openjdk-javadoc-1.8.0.65-0.b17.el6_7.noarch.rpm
java-1.8.0-openjdk-javadoc-debug java-1.8.0-openjdk-javadoc-debug-1.8.0.65-0.b17.el6_7.noarch.rpm
java-1.8.0-openjdk-src java-1.8.0-openjdk-src-1.8.0.65-0.b17.el6_7.i686.rpm
java-1.8.0-openjdk-src java-1.8.0-openjdk-src-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-src-debug java-1.8.0-openjdk-src-debug-1.8.0.65-0.b17.el6_7.x86_64.rpm
java-1.8.0-openjdk-src-debug java-1.8.0-openjdk-src-debug-1.8.0.65-0.b17.el6_7.i686.rpm
7 java-1.8.0-openjdk java-1.8.0-openjdk-1.8.0.65-2.b17.el7_1.x86_64.rpm
java-1.8.0-openjdk java-1.8.0-openjdk-1.8.0.65-2.b17.el7_1.src.rpm
java-1.8.0-openjdk-accessibility java-1.8.0-openjdk-accessibility-1.8.0.65-2.b17.el7_1.x86_64.rpm
java-1.8.0-openjdk-demo java-1.8.0-openjdk-demo-1.8.0.65-2.b17.el7_1.x86_64.rpm
java-1.8.0-openjdk-devel java-1.8.0-openjdk-devel-1.8.0.65-2.b17.el7_1.x86_64.rpm
java-1.8.0-openjdk-headless java-1.8.0-openjdk-headless-1.8.0.65-2.b17.el7_1.x86_64.rpm
java-1.8.0-openjdk-javadoc java-1.8.0-openjdk-javadoc-1.8.0.65-2.b17.el7_1.noarch.rpm
java-1.8.0-openjdk-src java-1.8.0-openjdk-src-1.8.0.65-2.b17.el7_1.x86_64.rpm