Important CentOS postgresql Security Update

Metadata

medium
5.0
postgresql-8.4.20-5.el6_7.i686.rpm, postgresql-8.4.20-5.el6_7.src.rpm, postgresql-8.4.20-5.el6_7.x86_64.rpm, postgresql-contrib-8.4.20-5.el6_7.i686.rpm, postgresql-contrib-8.4.20-5.el6_7.x86_64.rpm, postgresql-devel-8.4.20-5.el6_7.i686.rpm, postgresql-devel-8.4.20-5.el6_7.x86_64.rpm, postgresql-docs-8.4.20-5.el6_7.i686.rpm, postgresql-docs-8.4.20-5.el6_7.x86_64.rpm, postgresql-libs-8.4.20-5.el6_7.i686.rpm, postgresql-libs-8.4.20-5.el6_7.x86_64.rpm, postgresql-plperl-8.4.20-5.el6_7.i686.rpm, postgresql-plperl-8.4.20-5.el6_7.x86_64.rpm, postgresql-plpython-8.4.20-5.el6_7.i686.rpm, postgresql-plpython-8.4.20-5.el6_7.x86_64.rpm, postgresql-pltcl-8.4.20-5.el6_7.i686.rpm, postgresql-pltcl-8.4.20-5.el6_7.x86_64.rpm, postgresql-server-8.4.20-5.el6_7.i686.rpm, postgresql-server-8.4.20-5.el6_7.x86_64.rpm, postgresql-test-8.4.20-5.el6_7.i686.rpm, postgresql-test-8.4.20-5.el6_7.x86_64.rpm
CVE-2016-0773
rhn.redhat.com, lists.centos.org
2016-03-02
2017-07-27 19:10
ALAS-2016-662
ALAS-2016-689
Important CentOS postgresql Security Update
CVE-2016-0773 postgresql-9.5
CVE-2016-0773 postgresql-9.1
CVE-2016-0773 postgresql-9.4
CVE-2016-0773
2017-04-01 19:09
2017-01-05 20:13

Description


Updated postgresql packages that fix one security issue are now available
for Red Hat Enterprise Linux 6.

Red Hat Product Security has rated this update as having Important security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

PostgreSQL is an advanced object-relational database management system
(DBMS).

An integer overflow flaw, leading to a heap-based buffer overflow, was
found in the PostgreSQL handling code for regular expressions. A remote
attacker could use a specially crafted regular expression to cause
PostgreSQL to crash or possibly execute arbitrary code. (CVE-2016-0773)

Red Hat would like to thank PostgreSQL upstream for reporting this issue.
Upstream acknowledges Tom Lane and Greg Stark as the original reporters.

All PostgreSQL users are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue. If the postgresql
service is running, it will be automatically restarted after installing
this update.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 postgresql postgresql-8.4.20-5.el6_7.i686.rpm
postgresql postgresql-8.4.20-5.el6_7.src.rpm
postgresql postgresql-8.4.20-5.el6_7.x86_64.rpm
postgresql-contrib postgresql-contrib-8.4.20-5.el6_7.i686.rpm
postgresql-contrib postgresql-contrib-8.4.20-5.el6_7.x86_64.rpm
postgresql-devel postgresql-devel-8.4.20-5.el6_7.i686.rpm
postgresql-devel postgresql-devel-8.4.20-5.el6_7.x86_64.rpm
postgresql-docs postgresql-docs-8.4.20-5.el6_7.i686.rpm
postgresql-docs postgresql-docs-8.4.20-5.el6_7.x86_64.rpm
postgresql-libs postgresql-libs-8.4.20-5.el6_7.i686.rpm
postgresql-libs postgresql-libs-8.4.20-5.el6_7.x86_64.rpm
postgresql-plperl postgresql-plperl-8.4.20-5.el6_7.i686.rpm
postgresql-plperl postgresql-plperl-8.4.20-5.el6_7.x86_64.rpm
postgresql-plpython postgresql-plpython-8.4.20-5.el6_7.i686.rpm
postgresql-plpython postgresql-plpython-8.4.20-5.el6_7.x86_64.rpm
postgresql-pltcl postgresql-pltcl-8.4.20-5.el6_7.i686.rpm
postgresql-pltcl postgresql-pltcl-8.4.20-5.el6_7.x86_64.rpm
postgresql-server postgresql-server-8.4.20-5.el6_7.i686.rpm
postgresql-server postgresql-server-8.4.20-5.el6_7.x86_64.rpm
postgresql-test postgresql-test-8.4.20-5.el6_7.i686.rpm
postgresql-test postgresql-test-8.4.20-5.el6_7.x86_64.rpm