Moderate CentOS samba Security Update

Metadata

medium
4.0
ctdb-4.2.3-12.el7_2.x86_64.rpm, ctdb-devel-4.2.3-12.el7_2.i686.rpm, ctdb-devel-4.2.3-12.el7_2.x86_64.rpm, ctdb-tests-4.2.3-12.el7_2.x86_64.rpm, libsmbclient-3.6.23-25.el6_7.i686.rpm, libsmbclient-3.6.23-25.el6_7.x86_64.rpm, libsmbclient-4.2.3-12.el7_2.i686.rpm, libsmbclient-4.2.3-12.el7_2.x86_64.rpm, libsmbclient-devel-3.6.23-25.el6_7.i686.rpm, libsmbclient-devel-3.6.23-25.el6_7.x86_64.rpm, libsmbclient-devel-4.2.3-12.el7_2.i686.rpm, libsmbclient-devel-4.2.3-12.el7_2.x86_64.rpm, libwbclient-4.2.3-12.el7_2.i686.rpm, libwbclient-4.2.3-12.el7_2.x86_64.rpm, libwbclient-devel-4.2.3-12.el7_2.i686.rpm, libwbclient-devel-4.2.3-12.el7_2.x86_64.rpm, samba-3.6.23-25.el6_7.i686.rpm, samba-3.6.23-25.el6_7.src.rpm, samba-3.6.23-25.el6_7.x86_64.rpm, samba-4.2.3-12.el7_2.src.rpm, samba-4.2.3-12.el7_2.x86_64.rpm, samba-client-3.6.23-25.el6_7.i686.rpm, samba-client-3.6.23-25.el6_7.x86_64.rpm, samba-client-4.2.3-12.el7_2.x86_64.rpm, samba-client-libs-4.2.3-12.el7_2.i686.rpm, samba-client-libs-4.2.3-12.el7_2.x86_64.rpm, samba-common-3.6.23-25.el6_7.i686.rpm, samba-common-3.6.23-25.el6_7.x86_64.rpm, samba-common-4.2.3-12.el7_2.noarch.rpm, samba-common-libs-4.2.3-12.el7_2.x86_64.rpm, samba-common-tools-4.2.3-12.el7_2.x86_64.rpm, samba-dc-4.2.3-12.el7_2.x86_64.rpm, samba-dc-libs-4.2.3-12.el7_2.x86_64.rpm, samba-devel-4.2.3-12.el7_2.i686.rpm, samba-devel-4.2.3-12.el7_2.x86_64.rpm, samba-doc-3.6.23-25.el6_7.i686.rpm, samba-doc-3.6.23-25.el6_7.x86_64.rpm, samba-domainjoin-gui-3.6.23-25.el6_7.i686.rpm, samba-domainjoin-gui-3.6.23-25.el6_7.x86_64.rpm, samba-glusterfs-3.6.23-25.el6_7.x86_64.rpm, samba-libs-4.2.3-12.el7_2.i686.rpm, samba-libs-4.2.3-12.el7_2.x86_64.rpm, samba-pidl-4.2.3-12.el7_2.noarch.rpm, samba-python-4.2.3-12.el7_2.x86_64.rpm, samba-swat-3.6.23-25.el6_7.i686.rpm, samba-swat-3.6.23-25.el6_7.x86_64.rpm, samba-test-4.2.3-12.el7_2.x86_64.rpm, samba-test-devel-4.2.3-12.el7_2.x86_64.rpm, samba-test-libs-4.2.3-12.el7_2.i686.rpm, samba-test-libs-4.2.3-12.el7_2.x86_64.rpm, samba-vfs-glusterfs-4.2.3-12.el7_2.x86_64.rpm, samba-winbind-3.6.23-25.el6_7.i686.rpm, samba-winbind-3.6.23-25.el6_7.x86_64.rpm, samba-winbind-4.2.3-12.el7_2.x86_64.rpm, samba-winbind-clients-3.6.23-25.el6_7.i686.rpm, samba-winbind-clients-3.6.23-25.el6_7.x86_64.rpm, samba-winbind-clients-4.2.3-12.el7_2.x86_64.rpm, samba-winbind-devel-3.6.23-25.el6_7.i686.rpm, samba-winbind-devel-3.6.23-25.el6_7.x86_64.rpm, samba-winbind-krb5-locator-3.6.23-25.el6_7.i686.rpm, samba-winbind-krb5-locator-3.6.23-25.el6_7.x86_64.rpm, samba-winbind-krb5-locator-4.2.3-12.el7_2.x86_64.rpm, samba-winbind-modules-4.2.3-12.el7_2.i686.rpm, samba-winbind-modules-4.2.3-12.el7_2.x86_64.rpm
CVE-2015-7560
rhn.redhat.com, lists.centos.org, lists.centos.org
2016-03-15
2017-07-27 19:10
ALAS-2016-674
Moderate CentOS samba4 Security Update
CVE-2015-7560 samba
CVE-2015-7560
2017-04-01 19:09
2017-01-05 20:13

Description


Updated samba packages that fix one security issue are now available
for Red Hat Enterprise Linux 6 and 7.

Red Hat Product Security has rated this update as having Moderate security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

Samba is an open-source implementation of the Server Message Block (SMB) or
Common Internet File System (CIFS) protocol, which allows PC-compatible
machines to share files, printers, and other information.

A flaw was found in the way Samba handled ACLs on symbolic links.
An authenticated user could use this flaw to gain access to an arbitrary
file or directory by overwriting its ACL. (CVE-2015-7560)

Red Hat would like to thank the Samba project for reporting this issue.
Upstream acknowledges Jeremy Allison (Google) and the Samba team as the
original reporters.

All samba users are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue. After installing this
update, the smb service will be restarted automatically.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
6 libsmbclient libsmbclient-3.6.23-25.el6_7.i686.rpm
libsmbclient libsmbclient-3.6.23-25.el6_7.x86_64.rpm
libsmbclient-devel libsmbclient-devel-3.6.23-25.el6_7.x86_64.rpm
libsmbclient-devel libsmbclient-devel-3.6.23-25.el6_7.i686.rpm
samba samba-3.6.23-25.el6_7.src.rpm
samba samba-3.6.23-25.el6_7.i686.rpm
samba samba-3.6.23-25.el6_7.x86_64.rpm
samba-client samba-client-3.6.23-25.el6_7.i686.rpm
samba-client samba-client-3.6.23-25.el6_7.x86_64.rpm
samba-common samba-common-3.6.23-25.el6_7.i686.rpm
samba-common samba-common-3.6.23-25.el6_7.x86_64.rpm
samba-doc samba-doc-3.6.23-25.el6_7.x86_64.rpm
samba-doc samba-doc-3.6.23-25.el6_7.i686.rpm
samba-domainjoin-gui samba-domainjoin-gui-3.6.23-25.el6_7.x86_64.rpm
samba-domainjoin-gui samba-domainjoin-gui-3.6.23-25.el6_7.i686.rpm
samba-glusterfs samba-glusterfs-3.6.23-25.el6_7.x86_64.rpm
samba-swat samba-swat-3.6.23-25.el6_7.i686.rpm
samba-swat samba-swat-3.6.23-25.el6_7.x86_64.rpm
samba-winbind samba-winbind-3.6.23-25.el6_7.i686.rpm
samba-winbind samba-winbind-3.6.23-25.el6_7.x86_64.rpm
samba-winbind-clients samba-winbind-clients-3.6.23-25.el6_7.i686.rpm
samba-winbind-clients samba-winbind-clients-3.6.23-25.el6_7.x86_64.rpm
samba-winbind-devel samba-winbind-devel-3.6.23-25.el6_7.i686.rpm
samba-winbind-devel samba-winbind-devel-3.6.23-25.el6_7.x86_64.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-3.6.23-25.el6_7.x86_64.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-3.6.23-25.el6_7.i686.rpm
7 ctdb ctdb-4.2.3-12.el7_2.x86_64.rpm
ctdb-devel ctdb-devel-4.2.3-12.el7_2.x86_64.rpm
ctdb-devel ctdb-devel-4.2.3-12.el7_2.i686.rpm
ctdb-tests ctdb-tests-4.2.3-12.el7_2.x86_64.rpm
libsmbclient libsmbclient-4.2.3-12.el7_2.x86_64.rpm
libsmbclient libsmbclient-4.2.3-12.el7_2.i686.rpm
libsmbclient-devel libsmbclient-devel-4.2.3-12.el7_2.x86_64.rpm
libsmbclient-devel libsmbclient-devel-4.2.3-12.el7_2.i686.rpm
libwbclient libwbclient-4.2.3-12.el7_2.x86_64.rpm
libwbclient libwbclient-4.2.3-12.el7_2.i686.rpm
libwbclient-devel libwbclient-devel-4.2.3-12.el7_2.i686.rpm
libwbclient-devel libwbclient-devel-4.2.3-12.el7_2.x86_64.rpm
samba samba-4.2.3-12.el7_2.src.rpm
samba samba-4.2.3-12.el7_2.x86_64.rpm
samba-client samba-client-4.2.3-12.el7_2.x86_64.rpm
samba-client-libs samba-client-libs-4.2.3-12.el7_2.x86_64.rpm
samba-client-libs samba-client-libs-4.2.3-12.el7_2.i686.rpm
samba-common samba-common-4.2.3-12.el7_2.noarch.rpm
samba-common-libs samba-common-libs-4.2.3-12.el7_2.x86_64.rpm
samba-common-tools samba-common-tools-4.2.3-12.el7_2.x86_64.rpm
samba-dc samba-dc-4.2.3-12.el7_2.x86_64.rpm
samba-dc-libs samba-dc-libs-4.2.3-12.el7_2.x86_64.rpm
samba-devel samba-devel-4.2.3-12.el7_2.i686.rpm
samba-devel samba-devel-4.2.3-12.el7_2.x86_64.rpm
samba-libs samba-libs-4.2.3-12.el7_2.x86_64.rpm
samba-libs samba-libs-4.2.3-12.el7_2.i686.rpm
samba-pidl samba-pidl-4.2.3-12.el7_2.noarch.rpm
samba-python samba-python-4.2.3-12.el7_2.x86_64.rpm
samba-test samba-test-4.2.3-12.el7_2.x86_64.rpm
samba-test-devel samba-test-devel-4.2.3-12.el7_2.x86_64.rpm
samba-test-libs samba-test-libs-4.2.3-12.el7_2.x86_64.rpm
samba-test-libs samba-test-libs-4.2.3-12.el7_2.i686.rpm
samba-vfs-glusterfs samba-vfs-glusterfs-4.2.3-12.el7_2.x86_64.rpm
samba-winbind samba-winbind-4.2.3-12.el7_2.x86_64.rpm
samba-winbind-clients samba-winbind-clients-4.2.3-12.el7_2.x86_64.rpm
samba-winbind-krb5-locator samba-winbind-krb5-locator-4.2.3-12.el7_2.x86_64.rpm
samba-winbind-modules samba-winbind-modules-4.2.3-12.el7_2.i686.rpm
samba-winbind-modules samba-winbind-modules-4.2.3-12.el7_2.x86_64.rpm