Important CentOS openssl Security Update

Metadata

critical
10.0
openssl-0.9.8e-40.el5_11.i386.rpm, openssl-0.9.8e-40.el5_11.i686.rpm, openssl-0.9.8e-40.el5_11.src.rpm, openssl-0.9.8e-40.el5_11.x86_64.rpm, openssl-devel-0.9.8e-40.el5_11.i386.rpm, openssl-devel-0.9.8e-40.el5_11.x86_64.rpm, openssl-perl-0.9.8e-40.el5_11.i386.rpm, openssl-perl-0.9.8e-40.el5_11.x86_64.rpm
CVE-2016-2108
rhn.redhat.com, lists.centos.org
2016-05-31
2017-07-27 19:11
ALAS-2016-695
Important CentOS openssl Security Update
Important CentOS openssl Security Update
CVE-2016-2108 openssl
CVE-2016-2108
2017-04-14 09:03
2017-04-01 19:09
2017-02-25 10:03
2017-01-05 20:14

Description


An update for openssl is now available for Red Hat Enterprise Linux 5.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

OpenSSL is a toolkit that implements the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) protocols, as well as a full-strength general-purpose cryptography library.

Security Fix(es):

* A flaw was found in the way OpenSSL encoded certain ASN.1 data structures. An attacker could use this flaw to create a specially crafted certificate which, when verified or re-encoded by OpenSSL, could cause it to crash, or execute arbitrary code using the permissions of the user running an application compiled against the OpenSSL library. (CVE-2016-2108)

Red Hat would like to thank the OpenSSL project for reporting this issue. Upstream acknowledges Huzaifa Sidhpurwala (Red Hat), Hanno Böck, and David Benjamin (Google) as the original reporters.
Please see https://www.redhat.com/footer/terms-of-use.html

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
5 openssl openssl-0.9.8e-40.el5_11.i386.rpm
openssl openssl-0.9.8e-40.el5_11.i686.rpm
openssl openssl-0.9.8e-40.el5_11.src.rpm
openssl openssl-0.9.8e-40.el5_11.x86_64.rpm
openssl-devel openssl-devel-0.9.8e-40.el5_11.i386.rpm
openssl-devel openssl-devel-0.9.8e-40.el5_11.x86_64.rpm
openssl-perl openssl-perl-0.9.8e-40.el5_11.i386.rpm
openssl-perl openssl-perl-0.9.8e-40.el5_11.x86_64.rpm