Kafo default_values.yaml Insecure Permissions Local Information Disclosure

Metadata

low
1.9
kafo
CVE-2014-0135
osvdb.org
2014-03-13
2017-06-16 19:08
2017-04-01 19:10
2017-01-05 20:14

Description

Kafo contains a flaw that is due to the program using insecure world-readable permissions for the default_values.yaml file. This may allow a local attacker to gain access to password and other unspecified sensitive information located within the file.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
kafo ~> 0.3.17,>= 0.5.2 None