Data Injection Vulnerability in Active Record

Metadata

medium
6.8
activerecord
CVE-2014-0080
osvdb.org
2014-02-18
2017-06-16 19:08
CVE-2014-0080 ruby-activerecord-2.3
CVE-2014-0080 ruby-activerecord-3.2
CVE-2014-0080 rails
CVE-2014-0080
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw in connection_adapters/postgresql/cast.rb
in Active Record. This issue may allow a remote attacker to inject data
into PostgreSQL array columns via a specially crafted string.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activerecord ~> 4.0.3,>= 4.1.0.beta2 < 3.2.0,~> 3.2.0