Data Injection Vulnerability in Active Record

Metadata

high
7.5
activerecord
CVE-2014-3514
groups.google.com
2014-08-18
2017-06-16 19:10
CVE-2014-3514 ruby-activerecord-2.3
CVE-2014-3514 ruby-activerecord-3.2
CVE-2014-3514 rails
CVE-2014-3514
2017-04-01 19:10
2017-01-05 20:15

Description

The create_with functionality in Active Record was implemented incorrectly and completely bypasses the strong parameters protection. Applications which pass user-controlled values to create_with could allow attackers to set arbitrary attributes on models.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activerecord ~> 4.0.9,>= 4.1.5 < 4.0.0