SQL Injection Vulnerability in Active Record

Metadata

high
7.5
activerecord
CVE-2014-3483
osvdb.org
2014-07-02
2017-06-16 19:10
CVE-2014-3483 rails
CVE-2014-3483 ruby-activerecord-2.3
CVE-2014-3483 ruby-activerecord-3.2
CVE-2014-3483
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw that may allow carrying out an SQL injection attack.
The issue is due to the PostgreSQL adapter for Active Record not properly
sanitizing user-supplied input when quoting ranges. This may allow a remote
attacker to inject or manipulate SQL queries in the back-end database,
allowing for the manipulation or disclosure of arbitrary data.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activerecord ~> 4.0.7,>= 4.1.3 < 4.0.0