Ruby on Rails Active Record +serialize+ Helper YAML Attribute Handling Remote Code Execution

Metadata

critical
10.0
activerecord
CVE-2013-0277
osvdb.org
2013-02-11
2017-06-16 20:03
CVE-2013-0277 rails
CVE-2013-0277 ruby-activerecord-2.3
CVE-2013-0277
2017-06-16 19:02
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw in the +serialize+ helper in the Active Record.
The issue is triggered when the system is configured to allow users to
directly provide values to be serialized and deserialized using YAML.
With a specially crafted YAML attribute, a remote attacker can deserialize
arbitrary YAML and execute code associated with it.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activerecord ~> 2.3.17,>= 3.1.0 None