Ruby on Rails SafeBuffer Object [] Direct Manipulation XSS

Metadata

medium
4.3
activesupport
CVE-2012-1098
osvdb.org
2012-03-01
2017-06-16 18:59
CVE-2012-1098 rails
CVE-2012-1098 ruby-actionpack-2.3
CVE-2012-1098
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw that allows a remote cross-site scripting (XSS)
attack. This flaw exists because athe application does not validate direct
manipulations of SafeBuffer objects via '[]' and other methods. This may
allow a user to create a specially crafted request that would execute
arbitrary script code in a user's browser within the trust relationship
between their browser and the server.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activesupport ~> 3.0.12,~> 3.1.4,>= 3.2.2 < 3.0.0