XML Parsing Vulnerability affecting JRuby users

Metadata

medium
5.8
activesupport
CVE-2013-1856
osvdb.org
2013-03-19
2017-06-16 19:03
CVE-2013-1856 ruby-activesupport-2.3
CVE-2013-1856 rails
CVE-2013-1856 ruby-activesupport-3.2
CVE-2013-1856
2017-04-01 19:10
2017-01-05 20:15

Description

The ActiveSupport XML parsing functionality supports multiple
pluggable backends. One backend supported for JRuby users is
ActiveSupport::XmlMini_JDOM which makes use of the
javax.xml.parsers.DocumentBuilder class. In some JVM configurations
the default settings of that class can allow an attacker to construct
XML which, when parsed, will contain the contents of arbitrary URLs
including files from the application server. They may also allow for
various denial of service attacks. Action Pack

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activesupport ~> 3.1.12,>= 3.2.13 ~> 2.3.0