Ruby on Rails HTML Escaping Code XSS

Metadata

medium
4.3
activesupport
CVE-2012-3464
osvdb.org
2012-08-09
2017-06-16 19:00
CVE-2012-3464 ruby-actionpack-3.2
CVE-2012-3464 rails
CVE-2012-3464
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw that allows a remote cross-site scripting (XSS)
attack. This flaw exists because the HTML escaping code functionality does
not properly escape a single quote character. This may allow a user to create
a specially crafted request that would execute arbitrary script code in a
user's browser within the trust relationship between their browser and the
server.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
activesupport ~> 3.0.17,~> 3.1.8,>= 3.2.8 None