XSS Vulnerability in number_to_currency

Metadata

medium
4.3
actionpack
CVE-2013-6415
groups.google.com
2013-12-03
2017-06-16 19:07
CVE-2013-6415 ruby-actionpack-2.3
CVE-2013-6415 ruby-actionpack-3.2
CVE-2013-6415 rails
CVE-2013-6415
2017-04-01 19:10
2017-01-05 20:15

Description

There is an XSS vulnerability in the number_to_currency helper in Ruby on Raile.
The number_to_currency helper allows users to nicely format a numeric value. One
of the parameters to the helper (unit) is not escaped correctly. Applications
which pass user controlled data as the unit parameter are vulnerable to an XSS attack.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 3.2.16,>= 4.0.2 None