Reflective XSS Vulnerability in Ruby on Rails

Metadata

medium
4.3
actionpack
CVE-2013-4491
groups.google.com
2013-12-03
2017-06-16 19:05
CVE-2013-4491 ruby-actionpack-3.2
CVE-2013-4491 rails
CVE-2013-4491 ruby-actionpack-2.3
CVE-2013-4491
2017-04-01 19:10
2017-01-05 20:15

Description

There is a vulnerability in the internationalization component of Ruby on
Rails. Under certain common configurations an attacker can provide specially
crafted input which will execute a reflective XSS attack.

The root cause of this issue is a vulnerability in the i18n gem which has
been assigned the identifier CVE-2013-4492.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 3.2.16,>= 4.0.2 None