XSS Vulnerability in number_to_currency, number_to_percentage and number_to_human

Metadata

medium
4.3
actionpack
CVE-2014-0081
osvdb.org
2014-02-18
2017-06-16 19:08
Moderate ruby193-rubygem-actionpack SCL Security Update
CVE-2014-0081 rails
CVE-2014-0081 ruby-actionpack-2.3
CVE-2014-0081 ruby-actionpack-3.2
CVE-2014-0081
2017-04-01 19:10
2017-01-05 20:15

Description

Ruby on Rails contains a flaw that allows a cross-site scripting (XSS) attack.
This flaw exists because the actionpack/lib/action_view/helpers/number_helper.rb
script does not validate input to the 'number_to_currency', 'number_to_percentage',
and 'number_to_human' helpers before returning it to users. This may allow a
remote attacker to create a specially crafted request that would execute arbitrary
script code in a user's browser session within the trust relationship between
their browser and the server.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 3.2.17,~> 4.0.3,>= 4.1.0.beta2 None