Object leak vulnerability for wildcard controller routes in Action Pack

Metadata

medium
5.0
actionpack
CVE-2015-7581
groups.google.com
2016-01-25
2017-06-16 19:16
CVE-2015-7581 ruby-actionpack-3.2
CVE-2015-7581 rails
CVE-2015-7581 ruby-actionpack-2.3
CVE-2015-7581
2017-04-01 19:10
2017-01-05 20:15

Description

There is an object leak vulnerability for wildcard controllers in Action Pack.
This vulnerability has been assigned the CVE identifier CVE-2015-7581.

Versions Affected: >= 4.0.0 and < 5.0.0.beta1
Not affected: < 4.0.0, 5.0.0.beta1 and newer
Fixed Versions: 4.2.5.1, 4.1.14.1

Impact
------
Users that have a route that contains the string ":controller" are susceptible
to objects being leaked globally which can lead to unbounded memory growth.
To identify if your application is vulnerable, look for routes that contain
":controller".

Internally, Action Pack keeps a map of "url controller name" to "controller
class name". This map is cached globally, and is populated even if the
controller class doesn't actually exist.

All users running an affected release should either upgrade or use one of the
workarounds immediately.

Releases
--------
The FIXED releases are available at the normal locations.

Workarounds
-----------
There are no feasible workarounds for this issue.

Patches
-------
To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.

* 4-1-wildcard_route.patch - Patch for 4.1 series
* 4-2-wildcard_route.patch - Patch for 4.2 series

Please note that only the 4.1.x and 4.2.x series are supported at present. Users of earlier unsupported releases are advised to upgrade as soon as possible as we cannot guarantee the continued availability of security fixes for unsupported releases.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 4.2.5, >= 4.2.5.1,~> 4.1.14, >= 4.1.14.1 < 4.0.0,>= 5.0.0.beta1