XSS vulnerability in the translate helper method in Ruby on Rails

Metadata

medium
4.3
actionpack
CVE-2011-4319
groups.google.com
2011-11-17
2017-06-16 18:58
CVE-2011-4319 rails
CVE-2011-4319
2017-04-01 19:10
2017-01-05 20:15

Description

A cross-site scripting (XSS) flaw was found in the way the 'translate' helper
method of the Ruby on Rails performed HTML escaping of interpolated user
input, when interpolation in combination with HTML-safe translations were
used. A remote attacker could use this flaw to execute arbitrary HTML or web
script by providing a specially-crafted input to Ruby on Rails application,
using the ActionPack module and its 'translate' helper method without explicit
(application specific) sanitization of user provided input.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 3.0.11,>= 3.1.2 None