Possible remote code execution vulnerability in Action Pack

Metadata

high
7.5
actionpack
CVE-2016-2098
groups.google.com
2016-02-29
2017-06-16 19:18
CVE-2016-2098 ruby-actionpack-2.3
CVE-2016-2098 rails
CVE-2016-2098 ruby-actionpack-3.2
CVE-2016-2098
2017-04-01 19:10
2017-01-05 20:15

Description

There is a possible remote code execution vulnerability in Action Pack.
This vulnerability has been assigned the CVE identifier CVE-2016-2098.

Versions Affected: 3.2.x, 4.0.x, 4.1.x, 4.2.x
Not affected: 5.0+
Fixed Versions: 3.2.22.2, 4.1.14.2, 4.2.5.2

Impact
------
Applications that pass unverified user input to the `render` method in a
controller or a view may be vulnerable to a code injection.

Impacted code will look like this:

```ruby
class TestController < ApplicationController
def show
render params[:id]
end
end
```

An attacker could use the request parameters to coerce the above example
to execute arbitrary ruby code.

All users running an affected release should either upgrade or use one of
the workarounds immediately.

Releases
--------
The FIXED releases are available at the normal locations.

Workarounds
-----------
A workaround to this issue is to not pass arbitrary user input to the `render`
method. Instead, verify that data before passing it to the `render` method.

For example, change this:

```ruby
def index
render params[:id]
end
```

To this:

```ruby
def index
render verify_template(params[:id])
end

private
def verify_template(name)
# add verification logic particular to your application here
end
```

Patches
-------
To aid users who aren't able to upgrade immediately we have provided a
patch for it. It is in git-am format and consist of a single changeset.

* 3-2-secure_inline_with_params.patch - Patch for 3.2 series
* 4-1-secure_inline_with_params.patch - Patch for 4.1 series
* 4-2-secure_inline_with_params.patch - Patch for 4.2 series

Credits
-------
Thanks to both Tobias Kraze from makandra and joernchen of Phenoelit for
reporting this!

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack ~> 3.2.22.2,~> 4.2.5, >= 4.2.5.2,~> 4.1.14, >= 4.1.14.2 >= 5.0.0.beta1