Possible remote code execution vulnerability in Action Pack
There is a possible remote code execution vulnerability in Action Pack.
This vulnerability has been assigned the CVE identifier CVE-2016-2098.
Versions Affected: 3.2.x, 4.0.x, 4.1.x, 4.2.x
Not affected: 5.0+
Fixed Versions: 18.104.22.168, 22.214.171.124, 126.96.36.199
Applications that pass unverified user input to the `render` method in a
controller or a view may be vulnerable to a code injection.
Impacted code will look like this:
class TestController < ApplicationController
An attacker could use the request parameters to coerce the above example
to execute arbitrary ruby code.
All users running an affected release should either upgrade or use one of
the workarounds immediately.
The FIXED releases are available at the normal locations.
A workaround to this issue is to not pass arbitrary user input to the `render`
method. Instead, verify that data before passing it to the `render` method.
For example, change this:
# add verification logic particular to your application here
To aid users who aren't able to upgrade immediately we have provided a
patch for it. It is in git-am format and consist of a single changeset.
* 3-2-secure_inline_with_params.patch - Patch for 3.2 series
* 4-1-secure_inline_with_params.patch - Patch for 4.1 series
* 4-2-secure_inline_with_params.patch - Patch for 4.2 series
Thanks to both Tobias Kraze from makandra and joernchen of Phenoelit for
Am I vulnerable?
The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.
Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.Sign up for monitoring
Affected package information
|Package||Patched in||Unaffected in|