XSS Vulnerability in simple_format helper

Metadata

medium
4.3
actionpack
CVE-2013-6416
groups.google.com
2013-12-03
2017-06-16 19:07
CVE-2013-6416 ruby-actionpack-2.3
CVE-2013-6416 rails
CVE-2013-6416 ruby-actionpack-3.2
CVE-2013-6416
2017-04-01 19:10
2017-01-05 20:15

Description

There is a vulnerability in the simple_format helper in Ruby on Rails.
The simple_format helper converts user supplied text into html text
which is intended to be safe for display. A change made to the
implementation of this helper means that any user provided HTML
attributes will not be escaped correctly. As a result of this error,
applications which pass user-controlled data to be included as html
attributes will be vulnerable to an XSS attack.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
actionpack >= 4.0.2 ~> 2.3.0,~> 3.1.0,~> 3.2.0