Spree Multiple Script JSON Request Validation Weakness Remote Information Disclosure

Metadata

medium
5.0
spree
CVE-2010-3978
spreecommerce.com
2010-11-02
2017-06-16 18:55
2017-04-01 19:10
2017-01-05 20:15

Description

Spree contains a flaw that may lead to an unauthorized information
disclosure. The issue is triggered when the application exchanges data using
the JSON service without validating requests, which will disclose sensitive
user and order information to a context-dependent attacker when a logged-in
user visits a crafted website.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
spree ~> 0.11.2,>= 0.30.0 None