Potential Denial of Service Vulnerability in Rack

Metadata

medium
5.0
rack
CVE-2015-3225
groups.google.com
2015-06-16
2017-06-16 19:14
CVE-2015-3225 ruby-rack
CVE-2015-3225
2017-04-01 19:11
2017-01-05 20:15

Description

Carefully crafted requests can cause a `SystemStackError` and potentially
cause a denial of service attack.

All users running an affected release should upgrade.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
rack >= 1.6.2,~> 1.5.4,~> 1.4.6 None