Ruby Gem nori Parameter Parsing Remote Code Execution

Metadata

high
7.5
nori
CVE-2013-0285
osvdb.org
2013-01-10
2017-06-16 19:02
CVE-2013-0285
2017-04-01 19:11
2017-01-05 20:15

Description

The Ruby Gem nori has a parameter parsing error that may allow an attacker
to execute arbitrary code. This vulnerability has to do with type casting
during parsing, and is related to CVE-2013-0156.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Package Patched in Unaffected in
nori ~> 1.0.3,~> 1.1.4,>= 2.0.2 None