CVE-2011-4104 django-tastypie

Metadata

high
7.5
django-tastypie
CVE-2011-4104
2017-06-18 07:03
CVE-2011-4104
2017-06-16 18:58
2017-04-01 19:11
2017-01-05 20:16

Description

The from_yaml method in serializers.py in Django Tastypie before 0.9.10 does not properly deserialize YAML data, which allows remote attackers to execute arbitrary Python code via vectors related to the yaml.load method.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster django-tastypie 0.9.10-1
jessie django-tastypie 0.9.10-1
sid django-tastypie 0.9.10-1
stretch django-tastypie 0.9.10-1
wheezy django-tastypie 0.9.10-1