CVE-2009-4124 ruby1.9.1

Metadata

critical
10.0
ruby1.9.1
CVE-2009-4124
2017-06-16 18:52
CVE-2009-4124 ruby1.8
CVE-2009-4124
2017-04-01 19:11
2017-01-05 20:16

Description

Heap-based buffer overflow in the rb_str_justify function in string.c in Ruby 1.9.1 before 1.9.1-p376 allows context-dependent attackers to execute arbitrary code via unspecified vectors involving (1) String#ljust, (2) String#center, or (3) String#rjust. NOTE: some of these details are obtained from third party information.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
wheezy ruby1.9.1 1.9.1.376-1