CVE-2011-4815 ruby1.9.1

Metadata

high
7.8
ruby1.9.1
CVE-2011-4815
2017-06-16 18:58
ALAS-2012-35
CVE-2011-4815 ruby1.8
CVE-2011-4815
2017-04-01 19:11
2017-01-05 20:16

Description

Ruby (aka CRuby) before 1.8.7-p357 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

None

Unaffected

Release Package Reason
wheezy ruby1.9.1